Jump to content

andrewatfornax

Administrators
  • Content Count

    1,991
  • Joined

  • Last visited


Reputation Activity

  1. Upvote
    andrewatfornax reacted to victortoo in Changing Menu Names.   
    Thanks solved my issue.
    The language pack files are found in
    lib/max/language  folder in case anyone has an issue finding them.
     
  2. Upvote
    andrewatfornax reacted to lunaraurora in 5.0.5 upgrade but can not change database password   
    thanks, that's useful .. i will look into it
  3. Upvote
    andrewatfornax reacted to Ryan G in Statistics Will Not Show No Matter What, Help Sought   
    Thanks for this documentation @andrewatfornax - I was able to address this issue on my end. Was related to my plugins issue: https://forum.revive-adserver.com/topic/5683-upgrade-error-unable-to-locate-one-or-more-plugin-files/?tab=comments#comment-14335
  4. Upvote
    andrewatfornax got a reaction from Ryan G in Statistics Will Not Show No Matter What, Help Sought   
    https://documentation.revive-adserver.com/display/DOCS/Revive+Adserver+Broken
    https://documentation.revive-adserver.com/display/DOCS/No+Statistics
    ?
    In addition to the above, @Turbo212, I notice that your oxcd_data_bkt_m table is MyISAM. 
    This table type only supports table level locking.
    If you're under high load, it's possible that the table will be locked by delivery processes queued up to write their data when the hourly maintenance process wants to lock the table to make updates. Are you sure that's not happening? Your MySQL logs might give you more information on this.
  5. Upvote
    andrewatfornax got a reaction from Ryan G in Upgrade Error: Unable to locate one or more plugin files   
    Just to round out the thread and confirm, when you upgrade, the upgrade wizard will ask you where the old installation is located, so that it can find the previous installation's plugin files, and copy them over (so that any 3rd party plugins are retained) and upgrade them (if they are core Revive Adserver plugins and need to be updated).
  6. Upvote
    andrewatfornax reacted to bobdobs in HTML5 banner: Impression count too low v5.0.5   
    I figured it out myself 😀 The HTML5 banner relies on javascript to create an image that calls /www/delivery/lg.php. Now that js wasn't executing because it was in my Vue template, so I had to create a workaround. The stats collected in rv_data_bkt_m now match requests to /www/delivery/lg.php perfectly. 
  7. Upvote
    andrewatfornax reacted to Ian vM in Can't log in   
    try a password reset
  8. Like
    andrewatfornax got a reaction from Marc in Dashboard Broken   
    https://documentation.revive-adserver.com/display/DOCS/Revive+Adserver+Broken
  9. Upvote
    andrewatfornax reacted to adus in Extra redundancy   
    Thanks for the speedy reply!
    Yeah we make heavy use of AWS and RDS so sadly cant put the code on the DB server but I always meant to double check for scaling purposes if the task could lock as most of the php nodes would just be exact mirrors.
    I may spin a low end box up to handle the tasks but if I at least know it works as a mirrored then I can get under way with scaling anyway.
  10. Upvote
    andrewatfornax reacted to raulfg in ERROR IN GLOBAL STATS (Revive 5.0.5)   
    Forget this!
    Sorry ! The problem the check of production site is disabled! when i enable the check the warning dissapear! 
    The warnings appears on php 7.2 & 7.3 (I dont know what happen in inferior versions... )
  11. Like
    andrewatfornax got a reaction from adus in Extra redundancy   
    The maintenance process does have locking in place, to ensure that only once instance is triggered at a time, but personally, whenever I was managing a setup like that, I would put the Revive Adserver code on the central DB server too (even though it would not serve ads from there), and then run maintenance on that machine, so that there's no need for network traffic off-server to run maintenance.
    Every millisecond counts, right? 🙂
  12. Upvote
    andrewatfornax reacted to JLW in An error occurred while accessing the database   
    Resolved.... thank you for your comments.
  13. Upvote
    andrewatfornax reacted to scott001 in Issue with Upgrade to 5.0   
    Ok, it might take me a week or so, but I'll get it together...
  14. Upvote
    andrewatfornax reacted to Artistan in Insecure Cookies Warnings - Non-SSL Cookies   
    Our load balancer forwards requests to the web servers via port 80 (insecure on the local network)
    due to that, the web server + Revive does not automatically know that is should be serving secure links and cookies.
    In order to resolve this we had to add a forwarded header to the load balancer that tells the server + Revive code that the connection is secure from the users browser.
    search for `function setupConfigVariables` in the code to see what i am talking about, there are many different server settings to allow `$GLOBALS['_MAX']['SSL_REQUEST'] = true;`
  15. Upvote
    andrewatfornax reacted to tbobker in Using Google Adsense With Revive Adserver   
    Hi James,  you can setup a banner and connect the banner to any number of zones from multiple publishers. Is that what you wanted?
  16. Upvote
    andrewatfornax reacted to Artistan in Insecure Cookies   
    looks like this may be fixed in 
    Revive Adserver 5.0.4
  17. Like
    andrewatfornax got a reaction from Sudhir in 403 Error on Adding a new banner   
    HTTP 403 is a permission error. Check you webserver logs.
  18. Upvote
    andrewatfornax reacted to Matteo Beccati in Is 4.2.1 long-term stable?   
    No, there’s currently no LTS version. Only the latest releases normally get security fixes.
  19. Upvote
    andrewatfornax reacted to mitchems in Administrator Login loop on upgrade   
    I figured it out. I was installing the upgrade on a new AWS instance so that I wouldn't interrupt the old one. I found that it was still requiring HTTPS but I didn't have a cert on that server. By going into the host.domain,conf.php and changing requireSSL=1 to =0, that fixed my issue.
  20. Upvote
    andrewatfornax reacted to stapel_eliz in error messages since update to v4.2.1   
    The problem turned out to be that my server host hadn't actually updated PHP from version 5-point-somthing, despite my request that they do so (and assurances that they had). When Revive did the update (via cPanel's Softaculous), it asked if it could update the version of PHP but, though I'd said "yes", the update didn't apparently go through.
    The solution was to do the update myself.
    Thank you!
    Eliz.
  21. Like
    andrewatfornax got a reaction from levarberry in Does Revive provide an api interface   
    Yes, there is - there's an XML-RPC API for this. 
    Unfortunately, documentation for this is still on my todo list... But the API is there!
  22. Upvote
    andrewatfornax reacted to AgentPublishing in Redirected After Banner Upload   
    It does look like resetting cookies has helped! Thanks!
  23. Upvote
    andrewatfornax got a reaction from Keval SMS in Upload banners on Amazon S3 Bucket   
    There is no native support for this, no.
    However, depending on your system, you may be able to mount the S3 Bucket as a filesystem, and point Revive Adserver to that mount point for image storage.
  24. Upvote
    andrewatfornax got a reaction from Dofini in Add Delivery: Desktop / Mobile Only Option ?   
    Hi @manuel,
    Based on the order PHP "and" and "or" are applied (http://php.net/manual/en/language.operators.precedence.php), what you have is equivalent to:
    (Germany AND Windows) OR (OS X) OR (Linux). So, you need to set up in the UI:
    GEO Country Germany AND Operating System Version any Windows   OR GEO Country Germany AND Operating System Version any OS X OR GEO Country Germany AND Operating System Version any Linux I think that should do what you want, in one banner.
    ... This is where setting up targeting channels starts to make sense, so that you can more easily apply one or more channels.
  25. Downvote
    andrewatfornax reacted to michel in Loop redirection to the login page when the route is changed   
    I updated revive adserver from version 4.1.1 to 4.2.1, using the following path /adserver and everything worked correctly. Later  I changed the path to / , and the project started to redirect to the login page every time you click the options of the revive adserver. Can someone help me with this problem ?
×
×
  • Create New...