Jump to content

lunaraurora

Approved members
  • Content Count

    7
  • Joined

  • Last visited

  1. I contacted the plugin owners.. it seems a problem related to the plugin itself: we are aware that this plugin stopped working with Revive Adserver v5.0.x. Since this is one of our free plugins, we have not given it as much priority as the plugins for our paying customers. However, we do expect to get around to fixing this in the near future, and at that time it will be announced on our blog.
  2. Hello, i've upgraded to version 5.0.1 (with not few problems), now this plugin ( adserverplugins.com/magic-geo-macros) that i uses to show some flags geographically, no longer work, the images are broken (404). Also, under my banners inside the admin panel, i find this message: The cached delivery rules DO NOT AGREE with the delivery rules shown below Please hit save changes to update the cached delivery rules .. i know this is a bug that will be fixed, so my big concern now is the magic-geo-macros plugin which cause a big issue on my homepage. I spent almost a day with this errors, please someone can help me with this? I found this in my logs: Nov 14 01:41:05 +0000 OX-5dccb0b13333f [ info] Sync: No update on line 247 of /lib/RV/Sync.php on line 45 of /www/admin/maintenance-updates-js.php Nov 14 01:47:32 +0000 OX-5dccb2347e503 [ warning] AP_MagicGeo->convert: include(/plugins//deliveryLimitations/Geo/data/res-iso3166.inc.php): failed to open stream: No such file or directory on line 113 of /lib/max/ErrorHandler.php on line 105 of /plugins/deliveryAdRender/apMagicGeo/apMagicGeo.delivery.php on line 105 of /plugins/deliveryAdRender/apMagicGeo/apMagicGeo.delivery.php on line 64 of /plugins/deliveryAdRender/apMagicGeo/apMagicGeo.delivery.php on line 15 of /plugins/deliveryAdRender/apMagicGeo/apMagicGeo.delivery.php on line 702 of /lib/max/Delivery/common.php on line 190 of /lib/max/Delivery/adRender.php on line 34 of /www/admin/banner-htmlpreview.php Nov 14 01:47:32 +0000 OX-5dccb2347e503 [ warning] AP_MagicGeo->convert: include(): Failed opening '/plugins//deliveryLimitations/Geo/data/res-iso3166.inc.php' for inclusion (include_path='/lib/pear:/lib:.:/opt/cpanel/ea-php73/root/usr/share/pear') on line 113 of /lib/max/ErrorHandler.php on line 105 of /plugins/deliveryAdRender/apMagicGeo/apMagicGeo.delivery.php on line 105 of /plugins/deliveryAdRender/apMagicGeo/apMagicGeo.delivery.php on line 64 of /plugins/deliveryAdRender/apMagicGeo/apMagicGeo.delivery.php on line 15 of /plugins/deliveryAdRender/apMagicGeo/apMagicGeo.delivery.php on line 702 of /lib/max/Delivery/common.php on line 190 of /lib/max/Delivery/adRender.php on line 34 of /www/admin/banner-htmlpreview.php Nov 14 01:48:15 +0000 OX-5dccb25f64e36 [ warning] Smarty->display: count(): Parameter must be an array or an object that implements Countable on line 113 of /lib/max/ErrorHandler.php on line 96 of /var/templates_compiled/%%26^260^26060475%%plugin-group-view.html.php on line 1260 of /lib/smarty/Smarty.class.php on line 1106 of /lib/smarty/Smarty.class.php on line 196 of /lib/OA/Admin/Template.php on line 315 of /www/admin/plugin-index.php&quot
  3. Same problem here, also the option to select Countries are vanished, please let me know if someone understand the issue
  4. It's possible that by doing an upgrade but keeping the old database, it also show the old version of revive adserver. Edit database inside table: rv_application_variable and table name: oa_version change from 4.2.1 to 5.0.0 it should do the trick
  5. no suggestions? at the moment i just commented out this from file asyncjs.php: // The browser is allowed to cache this // if (!empty($conf['delivery']['assetClientCacheExpire'])) { // $expire = (int)$conf['delivery']['assetClientCacheExpire']; // header("Expire: ".gmdate('D, d M Y H:i:s \G\M\T', MAX_commonGetTimeNow() + $expire)); // header("Cache-Control: private, max-age={$expire}"); // } in way to get only the header directives of the redis plugin: cache-control max-age=864000 .. not sure if this is the best solution but fix the double header response
  6. Hi, thanks for the reply. This one: http://documentation.adserverplugins.com/redis-caching-plugin/ Sincerely i don't know if that's an official plugin or such site provides 3rd party plugins
  7. Hello, i tested with a header checker the file asyncjs.php served from my subdomain - and it results in a twice header cache-control response: cache-control private, max-age=3600, max-age=864000 I enabled Redis plugin and i found this portion of code inside the file apRedis.delivery.php: $result = $redis->setex($filename, $expire + 86400, $redis->serialize($cache_contents)); I believe is responsible for such double response.. i'm not a dev nor expert, could someone please suggest me how to fix it? Many thanks
×
×
  • Create New...