Jump to content
Erik Geurts

Using Google Adsense With Revive Adserver

Recommended Posts

Hello Erik

I have a problem with Revive, I am trying to create a new campaign, I have included all the zones, but i am not getting any impression in this campaign, What do you think problem might be

 

Thanks

Rajeesh

Share this post


Link to post
Share on other sites

The Problem I am currently having is in the statistics. Why is the Adserver showing 522 Ad Impressions and for the same period Google shows My Impressions at 24.

I need Help with This. I need to be able  to at least get close on the reconciliation.

Thanks

Greg

Share this post


Link to post
Share on other sites

Hi,

On firefox v43, the adsense banners are white and not loaded (we see in firebug that it remains loading/waiting).

You can see for example:

http://www.justbio.com/hosted-tools.html

how to sove this? It works well on Chrome, IE...

thanks

 

Check if you have an Ad blocker module installed in Firefox.

The Problem I am currently having is in the statistics. Why is the Adserver showing 522 Ad Impressions and for the same period Google shows My Impressions at 24.

I need Help with This. I need to be able  to at least get close on the reconciliation.

Thanks

Greg

Your Adserver is not loading Adsense ads quickly, it records the impression but users leave your page before the ad loads actually.

Hello Erik

I have a problem with Revive, I am trying to create a new campaign, I have included all the zones, but i am not getting any impression in this campaign, What do you think problem might be

 

Thanks

Rajeesh

Have you added any specific restriction to banners ? What's the type of that campaign ?

Share this post


Link to post
Share on other sites

Hello there,

I hope this is ok to be posted here.

I have read the  Using Google AdSense with Revive Adserver (thank you Erik Geurts )and played around with various settings but still i am unable to deliver AdSense to my drupal website.

I tried both synch and ansynch code from adsense. I can deliver other ads via iframe to my website. I tried fixed size, zone-banner-adsense 336x280. I tried generic html banner "don not alter html" and "google adsense" banner options. 

I cannot even preview the banner from adsense. 

Am i missing anything? Any suggestions? Is there a more detailed tutorial or video perhaps?

Thanks in advance 

John

Share this post


Link to post
Share on other sites

Hi Erik,

I have a different problem, it is with regard to Google Adsense "Responsive" ads, they have no dimensions as they can fit any screen size, currently Revive Adserver banner form allows generic html ads with dimensions only, this then prevents me from adding Google Adsense responsive ad code, you should update your version of Revive to allow for one to not specify dimensions for Google Adsense banners, should not be difficult, just a day of your programmer and coffee ;)

By the way what a great product especially seems only solution for my email campaigns.

 

Share this post


Link to post
Share on other sites
10 hours ago, andrewatfornax said:

Hi @NuMedia Direct Marketing,

Have you tried setting the banner dimensions to * x *? I know that you can do this for zones... it may work for banners too?

If you'd like to help us have "just a day" of programming time, please consider becoming a Patreon sponsor - thanks!

Hi @andrewatfornax

Thank you for your reply.

Unfortunately "*" not allowed for banners, which I think should be allowed, what I have done currently is set the width and height to large values, e.ge 1000 for width, and select the checkbox to not use iframes, when I check on Google Chrome "inspect code" I think Revive Adserver does not set the width in the CSS of the generated code, this worked for Google Adsense banner but I noticed one of my responsive links is not showing, not sure if its the responsive link or Revive Adserver.

I will update what happens. 

On the "day of programming", yes I may just do that , but may contribute things that also inline with our business needs.

 

 

Share this post


Link to post
Share on other sites

I've been unable to get any 3rd party ads to display, including Google Adsense ads. I've used this software since it was PHPAdsNew, so am well-versed in how to use it. I've gone through your guide in detail, but no matter what I do it serves blank white space instead of ads.

Interestingly Google Adwords campaigns that I made years ago are working fine, just not any new campaigns that I create.

I noticed that the old working Google Adsense banner fields look different, for example:

Old-Banner.jpg

 

and the new one is missing the Banner link area fields:

New-Banner2.jpg

 

Any help would be highly appreciated!

 

PS - The ads do display fine when embedded directly into a web page, just not when serving with Revive Adserver.

Edited by scott001
add image

Share this post


Link to post
Share on other sites

Hi @scott001,

Yes, we dropped the banner link field for newly created HTML banners a while ago, because it didn't really make sense in this day and age where an HTML banner may well have more than one link in it - it made more sense to let the HTML itself define the link(s) required, rather than the (we felt) confusing setup which suggested only one link could possibly ever exist.

My suggestion on this would be to use a web developer toolkit (e.g. Google Chrome's web developer tools) to trace the flow of the ad delivery, and step through the constituent HTTP calls that are made during delivery. I suspect one of them is returning an HTTP error, or a blank result. First step in solving this is to figure out which one. (Compare and contrast to a working example, given you have one.)

Once you know where it's failing, you can start to debug.

 

As a note, though, I notice there's some HTTPS going on. I assume you have checked https://documentation.revive-adserver.com/display/DOCS/Banners+Not+Delivering+over+SSL ?

Share this post


Link to post
Share on other sites

I think I know what is going on @fede_2110. In your Google Adsense account go to My Ads > Content > Auto Ads. Then on the right click the pen (change your global settings), and turn off the "Text and Display Ads" setting. This setting allows google to put its ads where it wants to if you have this code in your page. Keep in mind that this may lower your earning, but you will be able to control where the ads go.

Share this post


Link to post
Share on other sites

These are great instructions.

 

Unfortunately, the ad clicks are not tracked through Revive, so there's no way to see how things are performing, unless you log into your Adsense account.

 

Not a major issue, but it would be nice to see how the Adsense ads perform relative to all other ads on the same site.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...