Jump to content

Serve only to a language country? [Not working/bug??]

Recommended Posts

We have an advertiser that only wish the ads to be displayed to US end-users and we have set the delivery rules as per screenshot:


but the ads are still served globally for some weird reason. Is this a bug or have we done this the wrong way? 

Example link: https://shorturl.gg/cmpKwo 
(Just hit reload a few times on that page and the Goldco ad will show up).

Thanks in advance for the help! 

Kind regards



Link to comment
Share on other sites

So according to the server documentation there should be serveral Geo options from the maxmind database plugin:https://documentation.revive-adserver.com/display/DOCS/Geotargeting+Delivery+Rules#GeotargetingDeliveryRules-Geo-Country/City

But when i look on the delivery rules under the banner there is no such options: 

  • Geo - Continent
  • Geo - Country
  • Geo - Latitude/Longitude
  • Geo - US/Canada Postal Code

Instead i only see this:


I have checked that the plugin is enabled too and it is. So i do not understand why it is not working properly. The geo options as I understand it should be listed in the drop down list right?

Any help with this would be very appreciated. ?


Kind regards


Hi thanks for the reply @andrewatfornax ?


Yes, i did try with both Danish and English (US) browser (firefox and Chrome), and the ads are still served when using Danish browser version..

What i am attempting to do is that I want to limit the ad serving to only one or a few countries. In this case to only US. But i just found out a few minutes ago (as you can see in my new positing above), that there should be some GEO settings in the system's drop down and it is missing on my server instance. 

Not sure how to fix this. 

Kind regards


Edited by AngryWarrior
Link to comment
Share on other sites

On the documentation page you have linked to about the geotargeting options, there is a section at the top of the page which talks about what to check if you can't see the geotargeting options.

For the browser language, as part of your testing, can you please check https://aruljohn.com/language.php to see what languages your browser accepts when you have it set in Danish mode?

Link to comment
Share on other sites

Hi @andrewatfornax

Thank you for your reply. 

If you are referring to updating and installing the Maxmind  database, I have already done that. I ahd some issues with it due to an update gone bad (it didn't finish the plugin update script in the end), which you can see here: 

 So I have indeed added the Maxmind license key in the Maxmind plugin section.. 


Not sure what can be wrong or what i might done wrong. 

Kind regards

Link to comment
Share on other sites

Hi Andre.

Here is the result from your link.

17 hours ago, andrewatfornax said:

For the browser language, as part of your testing, can you please check https://aruljohn.com/language.php to see what languages your browser accepts when you have it set in Danish mode?


I did try by using a Firefox portable us version. This is the result:



Do maybe have any idea on how I can solve this issue with the geo targeting issue? Below you find the settings of geo targeting in the system:

Geo targeting settings:


Plugin settings:


Detail view:


Setting view:


Thanks a  bunch!  :-) 

Kind regards


Edited by AngryWarrior
Link to comment
Share on other sites

Hi @andrewatfornax

Hmmm this is quite interesting... 

If I tick that check box:


It will display the geo targeting options in the banner delivery options drop down:


But if I tick of that same check box it will not display the drop down options with geo targeting. So what does this point to?

That the Maxmind database is still not installed even though I added a key for it or does this implicate something else? 

What can I /should I do to resolve this? 


Thanks again for your kind help. 

Kind regards


Edited by AngryWarrior
Link to comment
Share on other sites

i think I actually managed to solve this issue. :-)

  1. I deactivated and then deleted the Geo targeting plugin.
  2. Downloaded a fresh installation package of Revive
  3. Unzipped the package locally on my pc. I then uploading the geo targeting plugin zip file from the folder  etc/plugins/reviveMaxMindGeoIP2.zip
  4. Then as administrator head to plugins in the administrator dashboard  e.g. https://yourdomain.com//www/admin/plugin-index.php?selection=plugins and upload the zip package and enable it. (it should happen automatically):
  5. Then in that interface "plugins" chose the geo targeting plugin and click "Details" --> Settings --> License key. Go to Maxmind and generate a new license key https://www.maxmind.com/en/account/login 

    and then enter that new license key in the license field and hit "save". 
  6. Ok so next thing we need to do is to force Revive to initiate the download of the Maxmind database. So what yu need to do is to go back to the admin interface as admin and go to "plugins" e.g. https://yourdomain.com/www/admin/plugin-index.php.

    The way this is done is simple by clicking "disable" then wait a minute and then re-enable the plugin again by clicking "Activate". This will force Revive to start downloading the database from Maxmind.
  7. After the former step is done, then go to your Maxmind account and see if Revive has used your new key (confirms that it is working), result:
    As you can see in my case Revive has now done a data query for the Maxmind database and used the license key. :-) 
  8. Ok so the final step is to see that it is finally working and that Geo targeting is working and added to your drop down list in banner settings click your Banner --> Deliver options --> Add deliver rule dropdown.
  9. Final Result:
    So the whole problem I guess lies in the Revive never have downloaded the Maxmind database and thus it will therefor e not display the Geo targeting options in the Banner setting delivery options drop down for that reason. The solution is to follow the steps I provided above.  I hope this might help others that may encounter the same issue as I have and be a helpful solution. :-)

    Cheers everyone. 
    Kind regards
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...