Jump to content

MariaDB 10.2 Compatibility?


Recommended Posts

Is Revive Adserver compatible with MariaDB 10.2 ? I am currently running MariaDB 10.1, and see this warning when I go to upgrade:

MariaDB enables "strict mode" by default as of version 10.2. Strict mode controls how MariaDB and MySQL handle invalid or missing values in data-change statements such as INSERT or UPDATE. Applications not built with strict mode enabled may cause undesired behavior; please verify applications using MariaDB are compatible before upgrading. More information about strict mode is available here 

Link to comment
Share on other sites

Maybe the solution is for me to turn on strict mode on my current mariadb 10.1 using what I learned here:

https://www.liquidweb.com/kb/how-to-disable-mysql-strict-mode/

and see if everything goes ok? My concern is that bad things could start happening to the db without me noticing right away.

I was really hoping that the developers on this software could help with this more...who else should know this besides them? MariaDB is now the standard, and mysql support will end soon.

Link to comment
Share on other sites

  • 5 months later...
On 8/5/2018 at 8:57 PM, scott001 said:

Is Revive Adserver compatible with MariaDB 10.2 ?

Scott001, How are you making out with Revive and mariaDB? Did you have to disable strict mode?

Any other feedback on mariaDB overall? I'm trying to decide if I should convert from mySQL on a new server setup.

Link to comment
Share on other sites

  • 2 years later...

So I've always used Revive-Adervers and never had any problems. We have now also been using MySQL 10.4.17-MariaDB at our hoster (Domainfactory) since April 2020 and everything went well with that too.

Unfortunately, the update from v5.2.0 to v5.2.1 now fails and here in the forum I am only referred to the system requirements, which unfortunately does not help at all. At least for me.

If I don't get the problem resolved somehow, I'll have to look for something other adserver-tool.

Edited by dertutor
Hostername added
Link to comment
Share on other sites

On 7/12/2021 at 8:07 PM, scott001 said:

Also, I have strict mode off.

Hi,

sorry for the late response, was away from home.
The problem with the error is that apart from a picture of the error message that appears during the update process, I can't really tell you anything. It had always worked up to this version of Revive and now the message from the screenshot appears and I don't know what to do next.

"the strict mode is off", where do I switch this over for a test?

Screenshot:
https://ibb.co/Z8gKqjN

Best wishes,
Mario

Link to comment
Share on other sites

 Ohh man, sometimes I'm just stupid. For whatever reason I downloaded 5.1.0, but named Zip 5.2.1. The error message therefore probably meant that the version is older than the one already installed.

In the end I downloaded the whole package again and tried it again => it worked 🙂

Thank you so much! If I hadn't looked for an exact error message, I would probably never have noticed the wrong version number.

Screenshot: https://ibb.co/jJYZ3Dx

Best wishes,
Mario

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...