Jump to content

New images stopped uploading


Recommended Posts

Hi there. 

Revive ad was working fine until "something" happened.

Old banners are still being shown, however the new ones cannot be loaded.

When I choose new banner and click "Save changes" in banner-edit.php, the page reloads and displays a friendly green message informing me that "the banner has been changed". However, the banner does not appear on the top part of the page.

The new file also do not appear in /www/images

The permissions for

  • adserver_new/plugins’
  • ‘adserver_new/var’
  • ‘adserver_new/www/admin/plugins’
  • ‘adserver_new/www/images

are set to 777 and the path to images is correctly set in conf.php

I cannot check if a new entry appears in DB since I do not know where to look.

Nothing appears in debug.log either.
Current version: 3.1.0

I never worked with revive adserver until this issue appeared.

The only thing that I could think of is to update to later version and hope that this issue will resolve by itself after an update.

Once I tried to run an update(to 3.2.4) I received the following error message: 

Configuration of your webserver does not meet the requirements of the Revive Adserver.

Errors were found when detecting previous installations of Revive Adserver
We have detected integrity issues with your database. This means that the layout of your database differs from what we expect it to be. This could be due to customization of your database.


  1. - error writing changeset
  2. - database integrity check could not complete due to problems

(Couldn't for some reason attach a screenshot :200)

The database was not modified after revive adserver 3.1.0 was installed.

I just cloned it to another database as instructed.

The "user" has full permissions.

The debug.log and install.log are not being created in revive_new/var and not being modified in revive/var.

(Again, the /var permissions in both cases are being set to 777)

I would be very grateful for any help!

Thank you in advice!

P.s. I can create new campaigns.

P.s.s. If I try to load a banner that is currently used by another campaigns then it DOES appear after loading (banner-edit.php).




Link to comment
Share on other sites

I suggest re-reading the upgrade instructions, adserver_new is not supposed to be used "for real" after the upgrades, just as a temporary name to upload the new version into. Your config file now most likely does not reference adserver_new for the banner upload folder, but whatever the live folder name happened to be.

Link to comment
Share on other sites

Thank you for a promt reply!

I probably explain the situation not clear enough or my English is just not good enough.

1. The new version was never installed. I carried out all the necessary preparations. On the first step(once I agree to GNU licence and the system parameters are checked) the error message was displayed (see above in red) and I couldn't proceed any further. I still do not understand what exactly this error message means,

2. The images stopped uploading into the old version. The images folder is stored outside the revive folder. All pictures that are stored in it are seen by old campaigns but new ones do not appear.


Link to comment
Share on other sites

  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...