Jump to content

The Db Upgrade Not Load (From Openx V2.8 To Revive 3.0.2)


Mimer

Recommended Posts

Hi, 

 

I'm trying upgrade my OpenX 2.8 to Revive 3.0.2 but i have an issue... 

 

Thi's is what i do...

 

(my current add path is http://mypage.com/adserver/   -adserver- is the openx current install)

 

1- Unzip the revive to a _new directory  (http://mypage.com/adserver_new  -adserver_new- is the revive directory)

2- Create a new database.

3- Dump all the data from -adserver- database to my -new_database- (I check and re-check nd the tables are equal)

4- copy the -adserver- mypage.com.conf.php to -adserver_new- (in the /var/ directory)

5- In the -adserver_new- conf.php file, Change the old dabase info (name, username and pass) for the new database created in the step 2 <- I re check this and all it's OK

 

 

So....

 

Here is the problem...

 

When i Go to...  http://mypage.com/adserver_new/ the browser redirects to http://mypage.com/adserver/ 

 

Here I just have the login form, and when i write my Admin credentials 

 

Nothing more happens... It just load all the old server normally 

 

 

 

 

I've read a lot of posts here and try a lot of "solutions" like  put the database pass in " " but nothing more happens... the upgrade just don't start...

 

Please Help! 

 

And tnks a lot for the answer

Link to comment
Share on other sites

Hi,

 

I have verified your conf(hostname.conf.php) file.You specified that you have to redirect adserver url instead of adserver_new.So that you are always redirecting to adserver.

 

[webpath]
 
admin="myweb.com/adserver/www/admin"
delivery="myweb.com/adserver/www/delivery"
deliverySSL="myweb.com/adserver/www/delivery"
images="myweb.com/adserver/images"
imagesSSL="myweb.com/adserver/images"
 
Please make changes in above section aslike below,
 
[webpath]
admin="myweb.com/adserver_new/www/admin"

 

Link to comment
Share on other sites

Hi Eliza, tnks for the answer i've tried this before.... 

 

 

 

 
Please make changes in above section aslike below,
 
[webpath]
admin="myweb.com/adserver_new/www/admin"

 

 

 

And i can go to the /adserver_new/  Dashboard bot no to the updater.... 

 

And in the Update Section of the admin of my -adserver_new- I have and error and warning .  

 

http://edngt.com/cloud/public.php?service=files&t=ae873bcd07c4b446194038a77185f607

 

 

 

 


Actualmente está usando Revive Adserver v3.0.2 (warning: database is stamped as v2.8.10) funcionando bajo Apache, PHP 5.3.28 y MySQL 5.5.33-31.1.

 

 

The redirection still not work...

 

So... i change all the entries from -adserver- to -adserver_new- in the config file. and i have the same problem... the updater not runs...

 

:( 

Link to comment
Share on other sites

  • 2 weeks later...

Hi Mimer,

Try checking to database details in config file and domain name in var-->default.conf.php .

On default.conf.php i have...

;<?php exit; ?>
;*** DO NOT REMOVE THE LINE ABOVE ***
realConfig="edngt.com"

The database details are correct... I check and Re-Check a lot of times... 

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...