Jump to content

Installation error


Recommended Posts

I've just try to install revive.

But, I get this error message :

Fatal error: Uncaught exception 'Exception' with message 'Unable to set current step. Unknown step: login' in C:\xampp\htdocs\revive\lib\OX\Admin\UI\Wizard.php:138 Stack trace: #0 C:\xampp\htdocs\revive\lib\OX\Admin\UI\Wizard.php(83): OX_Admin_UI_Wizard->setCurrentStep('login') #1 C:\xampp\htdocs\revive\lib\OX\Admin\UI\Install\Wizard.php(31): OX_Admin_UI_Wizard->__construct('install', Array, Object(OX_Admin_UI_SessionStorage)) #2 C:\xampp\htdocs\revive\lib\OX\Admin\UI\Install\InstallController.php(298): OX_Admin_UI_Install_Wizard->__construct(Object(OX_Admin_UI_Install_InstallStatus), 'login') #3 C:\xampp\htdocs\revive\lib\OX\Admin\UI\Controller\BaseController.php(94): OX_Admin_UI_Install_InstallController->loginAction() #4 C:\xampp\htdocs\revive\lib\OX\Admin\UI\Controller\BaseController.php(82): OX_Admin_UI_Controller_BaseController->execute('login') #5 C:\xampp\htdocs\revive\www\admin\install.php(41): OX_Admin_UI_Controller_BaseController->process(Object(OX_Admin_UI_Controller_Request)) #6 C:\xampp\htdocs\revive\www\adm in C:\xampp\htdocs\revive\lib\OX\Admin\UI\Wizard.php on line138

Please tell me know what is the problem and how to solve this...

Thank you... 

Link to comment
Share on other sites

I have this exact same issue.

Attempting to install for the first time on Windows 7, Postgres 9.3, php 5.6, apache 2.4 (using "LoadModule php5_module c:/php/php5apache2_4.dll"), Chrome Version 45.0.2454.101 m.

The database was created, created admin user account, then it tried installing plugins (which all appeared to fail according to the logs) then it spit out the error/stack about 'login'.

After attempting to hit the revive site locally again it prompts for a login but when I provide the admin account information and click submit I get an error stating "You need to enable cookies before you can use Revive Adserver".

My cookies are enabled and I get this same series of errors whether using Chrome or Firefox.


Installation started 2015-10-16 17:44:16
Attempting to connect to database revive_adserver_3 with user revive_adserver
Connected to database revive_adserver_3
Database settings and permissions are OK
creating upgrade_action audit table
successfully created upgrade_action audit table
creating database_action audit table
successfully created database_action audit table
schema definition from cache TRUE
Installation created the core tables
Installation updated the schema version to 620
Installation updated the application version to 3.2.2
Preparing to set timezone preference...
Found timezone preference ID of 16
Found the admin account's timezone association, updating preference...
Updated the admin account timezone preference to: 'UTC'
#! openXBannerTypes(): Permissions error
#! openXDeliveryLimitations(): Permissions error
#! openX3rdPartyServers(): Permissions error
#! openXReports(): Permissions error
#! openXDeliveryCacheStore(): Permissions error
#! openXMaxMindGeoIP(): Permissions error
#! openXInvocationTags(): Permissions error
#! openXDeliveryLog(): Permissions error
#! openXVideoAds(): Permissions error

Any insights as I've spent hours trying to get this to work.

Thank you.


Link to comment
Share on other sites

  • 2 weeks later...

After banging my head against this for too many hours, I think I can describe the problem, and suggest a work around.

The fatal error in the installation from the OP ("Unable to set current step. Unknown step: login") is due to the plugins that are failing to install with the "Permissions error"; and the permissions error is because the automatic login as Admin has not worked.

In my original setup, I was running the server on my laptop as localhost:8080 and I noticed that the install was trying to set a cookie in domain 'localhost:8080' -  I believe the port number was causing a problem, and the cookie would not be returned in the next request, so the installation decides you are not logged in and not permitted to install the plugins.

This would also explain the errors we see about having to enable cookies, when cookies are working just fine...

To fix this I have done 2 things:

  1.  set a 3 level domain name in my hosts file that points to (ie revive.localhost.com)
  2. stopped trying to use a port number, and just listen on port 80

Now a fresh install correctly sets a sessionId cookie in the domain '.revive.localhost.com', the plugins install fine, and I can actually login to the test server again.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...