Jump to content
chris

Database Upgrade Issue from 2.8.11 to 3.2.5

Recommended Posts

Dear all,

I have just tried to upgrade from OpenX Source 2.8.11 to Revive Adserver v3.2.5 and received the following error message:

Failed to CREATE TEMPORARY TABLE - check your database permissions

Insufficient database permissions or incorrect database settings

I also would like to mention that I tried to perform the upgrade on a new Website in parallel. I followed the process carefully and copied the existing database of openx 2.8.11, put the revive files for 3.2.5 on the new website into an dedicated adserver folder, copied the content of the existing image folder into a new image folder on the new website and modified also the www.website.com.conf.php with the new website and database informations accordingly. Therefore everything should be normally fine.

But I received the above mentioned error message during the 3. step (Database) of the upgrading process.

Can someboday support on this?

Thanks in advance.

Chris

 

Share this post


Link to post
Share on other sites

The message is pretty clear, the MySQL username you're using doesn't have sufficient permissions to create new tables. I suggest given the user "all privileges" (as described in the installation documentation).

 

By the way, why do you intend to upgrade to an already out of date version? I recommend using the newest v4.0.0, see https://www.revive-adserver.com/download/

Share this post


Link to post
Share on other sites

Dear Erik,

thanks for the answer. In the meantime my hoster confirmed that he has to grant me those rights. I have originally thought that this issue is related to the upgrade, which I try to do on a new Website, rather than the old one. But I would like to be efficient and therefore going direclty to the new website and the new adserver version in parallel.

For your second point: Is it possible to go directly from openx 2.8.11 to revive 4.0.0? I thougt I have to go first through revive 3.2.5. Thanks to le me know.

Chris

Share this post


Link to post
Share on other sites

Dear Erik,

this sounds good, then I will upgrade directly to Revive Adserver 4.0.0.

One further question in this context concerning PHP. Can also integrate the Revive Adserver 4.0.0 source code for banners/zones into a website which runs with PHP 5.3 or PHP 5.4?

My new website, where I will upgrade the adserver to Revive Adserver 4.0.0, runs with PHP 5.6.

Would be great to let me know.

Chris

Share this post


Link to post
Share on other sites

If you're website runs on a server with an outdated PHP version, and you include the Revive Adserver invocation code in that site, then it should work.

Note: you will not integrate the Revive Adserver source code in the site, just some snippets of javascript code.

Share this post


Link to post
Share on other sites

Dear Eric,

the upgrade was successful beside the fact that I could not transfer the plugins due to the reason that I switched the website for the upgrade. But I was able to install them afterwards. I also tried to uninstall the two old plugins from openx, but I was not successful with the OpenX Market Plugin.

I have received the following error message:

Fatal error: require_once(): Failed opening required '/WWWROOT/xxxx/adserver/lib/OX/M2M/XmlRpcExecutor.php' (include_path='/WWWROOT/xxxx/adserver/lib/pear:/WWWROOT/xxxx/adserver/lib:.:/etc/php:/usr/local/share/php5.0:/usr/local/share/php5:/usr/local/share/php:/usr/share/php5.0:/usr/share/php5:/usr/share/php') in /WWWROOT/xxxx/adserver/www/admin/plugins/oxMarket/library/OX/oxMarket/pcApiClient/oxPublisherConsoleMarketPluginClient.php on line 30

What can I do in order to uninstall the OpenX Market Plugin as well?

Thank you.

Chris

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...