Jump to content
hokeycokey

Configure Scheduled Maintenance

Recommended Posts

Hi,

 

Just started looking after these servers and can't find any documentation on configuring the maintenance.  

 

Seeing the following warnings:

 

Scheduled maintenance hasn't run in the past hour. This may mean that you have not set it up correctly.

 

Can anyone point me to the documentation or explain how to configure this.

 

any pointers appreciated.

Thanks,

 

Share this post


Link to post
Share on other sites

happened to me. In my case it was because RV.php

Statistics doesnt work, so you have to change one line giving full path to PEAR.php, not just /lib/pear/PEAR.php

After I did this, statistics is working and I am not receiving message about maintance not runing

require_once '/COMPLETEPATHTODRECTORY/lib/pear/PEAR.php';

Share this post


Link to post
Share on other sites

Ever since our upgrade to Revive 3.0.5 a week ago, scheduled maintenance stopped running.  

 

So I've reactivated automatic maintenance for now.  

 

I checked and made sure the chron job is set up correctly.  

 

Is there some issue with the upgrade that could cause scheduled maintenance to stop like this?

Share this post


Link to post
Share on other sites

Ever since our upgrade to Revive 3.0.5 a week ago, scheduled maintenance stopped running.  

 

So I've reactivated automatic maintenance for now.  

 

I checked and made sure the chron job is set up correctly.  

 

Is there some issue with the upgrade that could cause scheduled maintenance to stop like this?

 

I just ran into this issue after upgrading from an earlier version of Revive. You have to pass a hostname as an additional parameter when you're calling the script from the command line. If you have this set up as a cron job, you need to change it there.

 

So, change this:

php /path/to/revive/maintenance/maintenance.php

 

To this:

php /path/to/revive/maintenance/maintenance.php localhost

 

There was apparently a bug in earlier versions that allowed you to call the script without the hostname parameter, which I didn't realize when I originally set up the cron. It was tricky to track down because there were no errors in debug.log.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...