Jump to content

Recommended Posts

I tried directly upgrade 414 to 502 but had the same error.  Thought it might be too big of a jump so I tried upgrading 414 420 and got the same error.  "One or more plugin files couldn't be located, check the install.log file for more information"

Install log file has this line Plugin: openX3rdPartyServers - Unable to locate file: /var/www/html/ads/extensions/3rdPartyServers/ox3rdPartyServers/doubleclick.class.php but seems to have an issue with multiple plugins.  

2020-01-08_1022

 

We don't use any additional plugins other than what come default.  I'm not finding anything close to helping with this issue.  Plus is 414 --> 520 upgrade path supported?

Thanks for any help.

Share this post


Link to post
Share on other sites

I did find one issue similar that suggest the permissions on the production installation could be off. I verified permission on production version are correct.  I also am using the path /var/www/html/ads in the upgrade process when it asks for old installation. I've upgrade Revive flawless over the years and am comfortable with the process.  So I'm a little surprised by this issue popping up.  Thanks again for any help given.

Share this post


Link to post
Share on other sites

I was able to upgrade 414 to 502 successfully (I think).  In my my 414 installation I removed all folders and files from the /plugins folder.  Ran the upgrade without flaw.  Then once into 502 admin portal it said it couldn't find the plugin xml files.  I copied up all the folders and files that I removed in the 414 installation.  Refreshed and 502 was happy.  So at this point I have a couple of questions.

1.  Since the 502 native archive file I downloaded has an empty /plugins directory did I handle this upgrade correctly?

2. How can I verify if my plugins are at the latest version since the Revive upgrade process didn't update any plugins?

Thanks for your help.

Share this post


Link to post
Share on other sites

1. The plugin files in the install package are in Revive Adserver's etc/plugins directory, and get copied over as part of the install/upgrade process, so an empty plugins directory in the downloaded package is correct.

2. You can look at the base plugins in the downloaded package's etc/plugins directory, and each plugin zip file will have details inside it relating to the exact version, if you want to manually compare the versions there with what you have.

https://documentation.revive-adserver.com/display/DOCS/Plugins+Incorrectly+Upgraded may assist with this.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...