Jump to content

Issue with Upgrade to 5.0


Recommended Posts

  • 3 weeks later...
  • 2 weeks later...

I'm having this same problem.

I've tried the upgrade several times now. When it completes the upgrade, all looks fine except these errors:

Installation of plugin "reviveMaxMindGeoIP2" failed:Server returned: 0
For all the plugins installed.

Logging in and checking the Updates section, same thing everyone else referred to. It says it's running 5.0.5 but DB is stamped 4.2.1.

I can provide a full zip of the Revive install + our database if this is still a mystery and there's no suggested solutions I can try.

thanks

 

Link to post
Share on other sites

I can confirm the same. We have just upgraded from 4.2.1 to 5.0.5:

  • Upgrade worked fine. No Errors during upgrade process.
  • However, we receive a warning in the Adservers product update page: (warning: database is stamped as v4.2.1)
Link to post
Share on other sites
  • 2 weeks later...

@Rich Y I have encountered the same hiccup with 'reviveMaxMindGeoIP2' as well.

Revive is looking for '/plugins/etc/openXMaxMindGeoIP.xml' which does not exist so I can't disable, update, or uninstall it. 

However when I view /etc/plugins/ I see 'reviveMaxMindGeoIP2.xml' in the folder, so maybe it is installed?

Link to post
Share on other sites
On 4/25/2020 at 1:23 PM, Ryan G said:

@Rich Y I have encountered the same hiccup with 'reviveMaxMindGeoIP2' as well.

Revive is looking for '/plugins/etc/openXMaxMindGeoIP.xml' which does not exist so I can't disable, update, or uninstall it. 

However when I view /etc/plugins/ I see 'reviveMaxMindGeoIP2.xml' in the folder, so maybe it is installed?

I'm not sure this was it, but I did get a debug.log message of permissions on my www/images folder. I went and check all my file permissions and didn't look like plugins was owned by www-data. I don't know if that fixed it for me... or if it was even a problem (I didn't think to check on the plugin first).

As for @manuel et al... the warning: database is stamped as v4.2.1 hopefully is just literally a record in the database that needs to reflect the newer upgrade version. But I am reluctant to just change the version stamp in the database, thinking that maybe the database has to run some update queries to actually get it up to the correct version.

I'm waiting on some direction here or from a Revive team member to help us all out with this question/issue.

Link to post
Share on other sites
  • 1 month later...

Hi all,

we are facing exactly the same issue. After following the update path to version 5.0.5 this message appears:

 

Sie nutzen derzeit Revive Adserver v5.0.5 (warning: database is stamped as v4.2.1) laufend auf Apache, PHP 7.2.29-1+0~20200320.39+debian9~1.gbp513c2e und MySQL 5.5.5-10.1.44-MariaDB-0+deb9u1.
 

Is editing the the value of oa_version in table rv_application_variable the appropiate workaround? Is the database migrated correctly?

What else can we do to perform this upgrade?

Please let us know if providing any data etc could help.

 

Thanks in Advance,

Jessica

 

Link to post
Share on other sites
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...