Jump to content
w-sky

Mistake during update, some plugins and extensions files lost

Recommended Posts

Hello there. I just updated to 4.2.1 and found a problem while importing plugins using the upgrade wizard, which probably was caused during the previous update. The mistake during the previous update was to enter a path containing ~ as path of the previous installation, and because this failed copying the plugins folder manually.

From install.log during this update now, with correct full path given, I found that the wizard was unable to find many files in "/www/admin/extensions/" (most in "/www/admin/extensions/videoReport/") and one specific file "/extensions/bannerTypeText/oxText/genericText.delivery.php"

I searched the folders of the old (4.2.0) installation and the new, but both "extensions" folders do not exist at all.
According to the log, at the end 3 plugins failed to import correctly:

Plugin: openXBannerTypes - Unable to locate XML files
Plugin: openXDeliveryLimitations - Unable to locate XML files
Plugin: openXVideoAds - Unable to locate XML files

However, all plugins are shown now in Admin menu, no errors or warnings here, and Revive 4.2.1 is working fine. Note that we are not using Video ads… but I am sure the plugins installation is not valid.

How can I check the consistency and how can I fix this? Should I uninstall the plugins and reinstall them?

 

Share this post


Link to post
Share on other sites

Thanks a lot! I guess I did not search enough, because I did not find those articles. 😕
Anyway, I have imported the code for the 3 plugins in question and seen from the backend, all seems to be fine.

Only at the details of "IAB VAST Video Player Plugin" and "IAB VAST Report Plugin" there is not table at all. (So also not a number in the Group column as a sign of a broken plugin.) But maybe this is normal?

Also, the /www/admin/extensions folder and its contents have not been re-created by importing the code … I am not sure if it's really fixed.

I did/do not notice any malfunctions, except during update, but I am not using Video ads.

Edited by w-sky

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...