Jump to content
netid83

Iframe zone refresh closes popups on latest chrome browsers

Recommended Posts

Hi,

I have an iframe zone activation code with a refresh interval of 5 secs. This is to rotate through a set of ads uniformly. 

The iframe is embedded in a main html page which has some window confirm & dialog boxes for the users. On latest versions of Chrome, 67.0.3396.99. 64 bit, when the users happen to open a confirm or an alert popup, they get closed automatically as soon as the iframe reloads after 5 secs.  This is causing the users to miss the confirm/alert messages.

I have tried this on a stand alone html page that has an iframe to another site (not an adserver) and reload it with a set interval on the html page. I have a button that opens a window confirm popup. This time the popup does not close automatically and waits for the user's action.

Here is my zone invocation code

<iframe id='af0b20f0' name='af0b20f0' src='http://ads.xyz.com/www/delivery/afr.php?refresh=5&amp;zoneid=12&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='160' height='600'><a href='http://ads.xyz.com/www/delivery/ck.php?n=acc02726&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://ads.xyz.com/www/delivery/avw.php?zoneid=12&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=acc02726' border='0' alt='' /></a></iframe>

When the iframe loads, it drops some html & js onto the iframe document.

<!DOCTYPE html PUBLIC '-//W3C//DTD XHTML 1.0 Transitional//EN' 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd'>
<html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en' lang='en'>
<head>
<title>Advertisement</title>

    <script type='text/javascript'><!--// <![CDATA[
        setTimeout('window.location.replace("http://ads.xyz.com/www/delivery/afr.php?refresh=5&zoneid=18&cb=INSERT_RANDOM_NUMBER_HERE&loc=")', 5000);
    // ]]> --></script><noscript><meta http-equiv='refresh' content='5;url=http://ads.xyz.com/www/delivery/afr.php?refresh=5&zoneid=18&cb=INSERT_RANDOM_NUMBER_HERE&loc='></noscript>
    <style type='text/css'>
body {margin:0; height:100%; background-color:transparent; width:100%; text-align:center;}
</style>
</head>
<body>
<img src='http://ads.xyz.com/www/images/cfb0de2dec5309a3dfd5e89b12193c42.jpg' width='160' height='600' alt='' title='' border='0' /><div id='beacon_d941a875e3' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://ads.xyz.com/www/delivery/lg.php?bannerid=233&amp;campaignid=90&amp;zoneid=18&amp;cb=d941a875e3' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div>
</body>
</html>

It has some thing to do with how adserver is reloading the iframe. What am I missing here? Is this a known issue with revive? Any solution or links that can help?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×