Jump to content

Cannot proceed wtih upgrade from 4.1.3 to 4.1.4.

Recommended Posts

I have performed quite many upgrades to newer versions over the years, following the instructions posted here every time as so many times before.

This time, however, attempting to upgrade from version 4.1.3 to 4.1.4   at the second step of the update process I get this alert which I don't seem to be able to get past.
I tried to copy the existing configuration file (for version 4.1.3) into the var folder for the new ( 4.1.4.) install as instructed in alert below - even though there is no such instructions in the general upgrade guide but trying it nonetheless - and that didn't change a thing either.  I am still stuck at this point.

Any ideas anybody?


Link to comment
Share on other sites

13 hours ago, Peter Symes said:
I tried to copy the existing configuration file (for version 4.1.3) into the var folder for the new ( 4.1.4.) install as instructed in alert below - even though there is no such instructions in the general upgrade guide

I think you should review the upgrade instructions again - copying your existing configuration file(s) from your existing installation to the new installation directory is a mandatory part of the upgrade process.

Without doing this, the new code base has no idea about your existing installation's details, and so cannot proceed with performing an upgrade.

Link to comment
Share on other sites

Perhaps I have not expressed myself clear enough.

I follow the instructions to the letter, as I have done so many times before over the last decade or so that I have used and upgraded to successive versions.

Among the steps, as pr the instructions,  is to make a backup, a new copy, of the database which is named according to version. The configuration file is also copied and after the database name, user and password has been edited to reflect the new copy of the database. This amended configuration file is the uploaded in the var sub-directory, in the new installation, as directed. 

Commencing the upgrade, the process obviously recognizes the database and all, hence the warning which is about something about the database. Usually the upgrade will continue smoothly but stops, and what is it about some old entries anyway? As the new code base is a fresh clone of the preexisting one, which is still the live version, it surely has all the details needed.

In any case, heeding the warning, even though it does not make much sense, I indeed tried putting the preexisting configuration file (with the older data base info) in the var folder instead as the prompt seem to suggest. That didn’t make any difference, it still does budge.

Second option was to try and change the table prefixes. That only produced an empty installation, functioning apparently but with no content.



Link to comment
Share on other sites

Hi @Peter Symes,

I'm always open to the possibility of there being a bug, but this looks to me like user error somewhere.

The issue is that during the upgrade process, the new Revive Adserver directory is not finding your configuration file, and so it's not automatically detecting the (copy) of your old database, and saying, yes, I can upgrade that.

Instead, it's asking you where the database should go, thinking that you're doing a new install, and when you tell it where the (copy) of your old database is, it's saying, hang on, this isn't right, there's already a database here - I thought I was doing a new install!

So, somewhere, your configuration file is missing / incorrect / not able to be read.....?

Link to comment
Share on other sites

OK, I got to the bottom of the mystery, but only after much head scratching

A while back, apparently after I did my previous upgrade,  our website's URL format was, at long last, changed from http://www.domainname.com to the secure protocol:  httpS://domainname.com.

While our site can be accessed both with and without the www prefix, we also changed the preferred default url from having the www prefix to not having it.  No problems, until I ran into this upgrade.

One or both of these changes was apparently more that the upgrade process could detect and bridge.  

Once I went through all the entries in the config.file, stripping all references therein of www prefixes and also renaming the config file from www.domainname.com.conf.php to domainname.com.conf.php the install process went flying through in an instant and without any further hiccups.

Thanks for providing feedback nonetheless.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...