Jump to content

Revive 4.1.4 Troubles with plugins

Recommended Posts

Tried to contact andrewatfornax regarding plugins missing on installation, however I was not able to message him, sorry for the inconvinience, I'll post my problem here.

* Installed by: downloading oficial tar.tgz file from website
* Installation method: uncompress, copy to local directory, git init uploaded to bitbucket and installed on remote server following instructions.
* Installation had PROBLEMS with CSS I guess was a PERMISSIONS issue. Fixed with  chmod -R a+w /home/erparom/webapps/adserve/www/admin/plugins
* No plugins were installed, so I followed instructions to upload zipped plugins.

When I try to install plugins, there is an error I get (for some of them: XVideoAds, all OpenXDelivery ones):

Invalid source path to plugin dataobjects /home/erparom/webapps/adserve/var/plugins/DataObjects/

Failed to implement dataobjects for vastInlineBannerTypeHtml

Task failed _registerSchema

Failed to write /home/erparom/webapps/adserve/var/plugins/DataObjects/db_schema.ini

Failed to recreate old dataobject cache

Invalid source path to plugin dataobjects /home/erparom/webapps/adserve/var/plugins/DataObjects/ for vastInlineBannerTypeHtml

Failed to remove dataobjects for vastInlineBannerTypeHtml

Failed to install vastInlineBannerTypeHtml

Failed to install plugins for package openXVideoAds

Failed to initialise table class for vastInlineBannerTypeHtml

Failed to drop tables for vastInlineBannerTypeHtml

Task failed _unregisterSchema

Failed to uninstall vastInlineBannerTypeHtml

Thanks a lot in advance for your very kind help!!!!

Link to comment
Share on other sites

  • 4 weeks later...

Hard to be sure, but looks like there were some permissions issues and possible database access issues as part of the initial installation.

Also, I'm not sure if the use of checking the code into git, and then checking it out on the server you're installing it on might have affected things?

Anyway, take a look at https://documentation.revive-adserver.com/display/DOCS/Directory+Permissions for the list of directories (and all files/directories underneath these) that must be able to be written to by the web server.

Also, please make sure that your database connection has full access to the Revive Adserver database. 


Link to comment
Share on other sites

  • 1 year later...

Hey all,

i know this topic is quite old, but i had exactly the same errors (after an upgrade to revive 5.0.0) and wasn't able to find a solution until now. Because of this i want to share here, if someone else in the future has the same problems. So here is the super simple solution that worked for me instantly:

Create the folder /var/plugins/DataObjects/ inside your adserver folder.

I hope this works for everyone else too ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...