Jump to content
tobean

Prohibit banner code hijacking

Recommended Posts

Hi!

How can I define that banners are only displayed on my own domain? If someone copies the banner code he can display the banners from our server to his pages.

I tried to modify the .htaccess file to prohibit this, but this was not successful.

Thanks for your help

tobean

Share this post


Link to post
Share on other sites

Help with setting up web server features like the .htaccess file is beyond the scope of this forum. However, in terms of what Revive Adserver can do, you could potentially use one of the Site Delivery Rules to limit where the banners are able to be shown. Please see: https://documentation.revive-adserver.com/display/DOCS/Site+Delivery+Rules

Share this post


Link to post
Share on other sites

Hi!

 

thank you. This option seemsl be perfect to solce the problem!

One questions: I can define these rules on banner or website basis. I guess this is the better option otherwise I must define the rules for every simgle banner.

But when I define a whitelist of domains on website basis, I cannot see the defined rule when I look at the deivery rules for a banner of the defined website.

I my configuration correct or where cann I see that it is a problem?

Best regards

tobean

Share this post


Link to post
Share on other sites

All my banners are linked to a zone, but I don't see the delivery rules defined on website basis there (Delivery Rules: No delivery rules).

I can define the rules for each banner individually but this would be a lot of work ... any other idea what's my mistake?

Share this post


Link to post
Share on other sites

I'm sorry, but there is definitely no " Site - Delivery Rule Set" on a banner page when I proceed as described in your manual.

I've found another way: When I go to "Preferences -> Delivery Rule Set Management" I can also "Add new Delivery Rule Set". And now I can go to the delivery option page of any banner and select the option "Site Channel" to find my delivery rule defined under "Preferences".

Is this another way to do the right thing or is your documentation not up to date? I use the newset version of revive.

Best regards

tobean

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×