Jump to content

Recommended Posts

Hello everybody.

I want to serve video ads and i get this error:

Failed to load https://adserver.tld/www/delivery/fc.php?script=bannerTypeHtml:vastInlineBannerTypeHtml:vastInlineHtml&format=vast&nz=1&zones=pre-roll%3D8: The value of the 'Access-Control-Allow-Origin' header in the response must not be the wildcard '*' when the request's credentials mode is 'include'. Origin 'https://imasdk.googleapis.com' is therefore not allowed access. The credentials mode of requests initiated by the XMLHttpRequest is controlled by the withCredentials attribute.

It's similar to the html5 banner error from version 4.1.1, that was fixed through update.

 

I want to show the video ad in a wordpress website with foliovision's fv player plugin and their VAST plugin.

 

Is here anyone who know how to fix this?

Thank you in advance

Maro

Share this post


Link to post
Share on other sites

Hi, thank you!

„This only applies to Flash-based video players. HTML5 video players do not require any crossdomain.xml policy file configuration.“

I already read this, but it seems to be only necessary for flash videos. I want to use only html5 videos.

Share this post


Link to post
Share on other sites

Well, the error you are seeing seems pretty clear:

The value of the 'Access-Control-Allow-Origin' header in the response must not be the wildcard '*' when the request's credentials mode is 'include'. Origin 'https://imasdk.googleapis.com' is therefore not allowed access.

Seems like setting something other than the wildcard might help?

 

Share this post


Link to post
Share on other sites
8 minutes ago, andrewatfornax said:

Well, the error you are seeing seems pretty clear:

The value of the 'Access-Control-Allow-Origin' header in the response must not be the wildcard '*' when the request's credentials mode is 'include'. Origin 'https://imasdk.googleapis.com' is therefore not allowed access.

Seems like setting something other than the wildcard might help?

 

I use Plesk server administration software. I can add additional headers but then it shows the error, that there are more than one directives. 

I dont know what this googleapi is, but if revive need this connection, than is the asterisk the right configuration, no?

 

Share this post


Link to post
Share on other sites

i tried this:

https://developers.google.com/interactive-media-ads/docs/sdks/html5/cors

but itis already true, so:

"The value of the 'Access-Control-Allow-Credentials' header in the response is 'true, true which must be 'true' when the request's credentials mode is 'include'. Origin 'https://thevideowebsitethatshouldshowthevideo.com' is therefore not allowed access. The credentials mode of requests initiated by the XMLHttpRequest is controlled by the withCredentials attribute."

Share this post


Link to post
Share on other sites

This is seen at the foliovision vast tester https://foliovision.com/player/vast/tester

FV VAST load (0,html5) https://servingdomain/www/delivery/fc.php?script=bannerTypeHtml:vastInlineBannerTypeHtml:vastInlineHtml&format=vast&nz=1&zones=pre-roll%3D8
fv-player-vast.min.js?ver=6.6.2.1:1 FV VAST Ads init.
fv-player-vast.min.js?ver=6.6.2.1:1 FV VAST Ad error: AdError 1010: The ad response was not understood and cannot be parsed.

After reload the CORS message is there again:

Failed to load https://servingdomain/www/delivery/fc.php?script=bannerTypeHtml:vastInlineBannerTypeHtml:vastInlineHtml&format=vast&nz=1&zones=pre-roll%3D8: The value of the 'Access-Control-Allow-Origin' header in the response must not be the wildcard '*' when the request's credentials mode is 'include'. Origin 'https://imasdk.googleapis.com' is therefore not allowed access. The credentials mode of requests initiated by the XMLHttpRequest is controlled by the withCredentials attribute.

 

Share this post


Link to post
Share on other sites

It seems to be gone, at this time there is no CORS Error.

With foliovision VAST Tester, i got this next error:

FV VAST Ad error: AdError 1010: The ad response was not understood and cannot be parsed.

 

Maybe the player doesn't support this Version of VAST? I also tried to use = instead of %3D after "...pre-roll..."

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×