Jump to content

Error during upgrade from 4.0.0 to 4.1.0

Recommended Posts


after the system check during the upgrade pocess the wizard returned a error message saying  that the system detected errors with the previous installation of the Revive Ad Server.

Apparently the database integrity check detected problems with the database and there are 98 fields to change. I suspect a problem with these 98 fields.

In order to see where the problem occurs from, I tried to import a backup of the DB into a new database which seemed to be successful  in the first place until I noticed that only one table  (ox_account_preference_assoc) got imported.

Further info:

Server version: 10.1.26-MariaDB

PHP version: 5.6.31-pl0-gentoo

So right now I am not able to import, check and fix the database.

Any ideas or suggestions how to proceed from here?


Cheers in advance. 



Share this post

Link to post
Share on other sites

It may be that you ran into an issue that was found in the upgrade process in v4.1.0 and that was fixed in v4.1.1. Please try if using the most recent version fixes this for you. See https://www.revive-adserver.com/download/ and https://www.revive-adserver.com/blog/revive-adserver-v4-1-1-released-bug-fixes/

Share this post

Link to post
Share on other sites

Hi Erik,

Thanks for your reply.

I can confirm that the issue has been fixed and as stated in your reply, originated from version 4.1.0. After installing 4.4.1 it worked straight away without any further errors.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now