Jump to content

Preferences Not Updating After Updating to 4.1.1


Recommended Posts

We are trying to update from 4.0.1 to 4.1.1 and ran into an issue with some of the preferences.  The banner preview wasn't showing so I checked the preferences page and that option was not selected, where it is still selected on the pre-update installation.  When you update the preferences and click save, it shows a green message box that the changes were saved but the options revert back.  The timezone is showing the same symptom.  The database user has full privileges to the database. 

The error logs are showing the following message multiple times:

Oct 25 09:58:46 -0400 OX-59f09895f0ca9 [  warning]  Declaration of HTML_QuickForm_file::_findValue() should be compatible with HTML_QuickForm_element::_findValue(&$values)

We are running MySQL 5.7.20 and PHP 7.0.22 on Linux (Ubuntu 16.04.3 LTS).  We've been running Revive for about a year and this is the first time we've had an issue upgrading.

Do you have any suggestions?  Thank you!

Link to comment
Share on other sites

We use Puppet for our configuration, so the two installations were identical except for the folder/database names.  I cloned the site to our test environment and everything worked as expected before the upgrade.  Then I performed the update there and it worked!

The only difference between this time and the other times I tried was cloning the site first instead of trying to upgrade directly to the staging environment.  Either way, it's working now so I'm happy!  Thank you for your assistance!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...