Jump to content

Can't Change Database User / PWRD

Recommended Posts

I'm having a strange problem with Revive server.  All I want to do is change the MYSQL username and password, and as soon as I do (in the Revive config file for the site), everything breaks.  In the banner location, it says it can't find the configuration file.  In the back-end, I get a page full of parsing errors instead of the admin page.

The strange thing is if the MYSQL username and password is reverted - even if it doesn't exist as an authorized username in mysql - Revive half works with banners showing up - but I can't get into the back-end.  The only way I can get back to normal is reverting the full username and password to the original.

Is part of the password reset in the database tables or is it 100% in the config file?

I'm currently running 4.0 on Windows Server 2012 (IIS 8).  PHP 5.6, MYSQL 5.7,18

If I do a fresh install of 4.02 it works as a fresh install, but I'm incapable of upgrading from my existing material.  it won't communicate with the database, etc.

Here is a sample of the error (minus back-end directories) when I'm changing the password.

MESSAGE: Redefining already defined constructor for class XML_Parser
TYPE: Strict
FILE: D:\site\...\lib\pear\XML\Parser.php
LINE: 204

199 * @param string $mode how this parser object should work, "event" for
200 * startelement/endelement-type events, "func"
201 * to have it call functions named after elements
202 * @param string $tgenc a valid target encoding
203 */

204 function __construct($srcenc = null, $mode = 'event', $tgtenc = null)

205 {
206 parent::__construct('XML_Parser_Error');
208 $this->mode = $mode;
209 $this->srcenc = $srcenc;


There are tonnes of errors on the page; this is just the first one.





Link to comment
Share on other sites

Hi @Enterfrize ,

My immediate reaction to hearing "when I change the configuration file, I get an error that it can't find the configuration file" is that, when you are editing the file, you're changing the ownership or permissions of the file from what's there originally, so that the web server cannot read the file anymore.

Can you please check that first?

Link to comment
Share on other sites


I inadvertently got around the problem which gave birth to a whack of new problems.

1. I reverted to the original username and password.

2. I performed an updated based on this configuration (I worked via a separate install and database as to not overwrite what I already had).

The upgrade worked.  After that, I was able to change the username and password for the database.  I may have cleared most of the cache directory as well thinking that there could be a remnant there looking for the original directory location - I don't remember for sure.

Now the new problem is even though banners are being served and I can get into the admin page, all the plugins aren't working as though they haven't been found / installed (though they are listed as active).

I'm debating doing a fresh install, copying the image files over, and pointing to the original updated database.  Any ideas?



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...