Jump to content
asset

campagin issue

Recommended Posts

Clicking  Inventory> Campaigns  produces this error 

Fatal error: Call to a member function getClientCampaigns() on a non-object in /home/xxxx/public_html/www/admin/advertiser-campaigns.php on line 114

Same error shows when clicking any of the listed advertisers?

 

can you help with this

Share this post


Link to post
Share on other sites

Hello,

 

We have the same issue with revive.

 

We are getting error as below.

Fatal error: Call to a member function getClientCampaigns() on a non-object in /home/XXXX/public_html/www/admin/advertiser-campaigns.php on line 129

 

The php version using are PHP 5.3.29

revive is 3.2.4

 

 

Share this post


Link to post
Share on other sites

I'm getting the exact same issue as @asset using 4.0.2. I tried setting this up on the same server a year ago and had the same issue. I've tried different ways of installing (Softaculous, official installer, and so on), I've tried increasing the memory limit in php.ini because a memory handling error was being thrown for the dashboard widgets, I've tried different domains and subdomains under the same hosting package, and more. I've even tried creating /lib/max/Dal/Admin/Campaigns.php because it was missing but somehow that would always delete itself. (Quite astounded by that one actually - cPanel showed the file as existing when blank but adding the contents saw it delete itself, although the file seems not to exist in the original installation zip so I haven't tried too hard. I'm probably not understanding something fundamental there. Edit: it does exist.)

Only the Inventory>Campaigns page completely fails, while the dashboard widgets take turns in showing 500 errors (which means Campaigns does sometimes show up there) with little consistency.

Completely at a loss as to how to fix this and would really appreciate some help. I'm presently using Revive on another server and it's great, but I need to install it on this one.

Thank you anyone who can help for doing so!

 

Update: I cloned the other install over and it works just fine. No idea why, but new installs just don't work!

 

Update 2: Nope! I changed the header image and suddenly I have the same problem again.

 

Update 3: Looks like Campaigns.php is gone again. Any ideas what's deleting it?

 

Update 4: Even uploading the file under a different name is seeing it deleted immediately. I'm starting to wonder if this server has some kind of antivirus which is incorrectly detecting something dodgy in the file.

Edited by WillPJK
Update 4

Share this post


Link to post
Share on other sites

I can't seem to edit the last post anymore, there must be a two-hour limit.

 

Anyway, update 5 is a potential breakthrough. I copied the code into the file section by section to check what would trigger the automatic deletion and nothing did. I got the full file in, albeit with slightly different line numbers. I think the fact there was a slight difference in the file might have saved it when it was finally completed. Someone must have reported the file as bad to my host or something because this very slightly modified version isn't going anywhere and is working just fine.

Update 6: nope, it's gone again, but it stuck around long enough for me to actually use the file.

Update 7: this seems to be a server or host issue - I just put the file in the root of a different domain hosted on the same server and it was gone in seconds too. If anyone is familiar with this issue and knows what to disable, please let me know. I have contacted my host. I assume ClamAV isn't the culprit, but I really don't know.

Update 8: the code which sees the file deleted is somewhere between lines 588 and 680. I'm going through and adding it back in bit by bit. The campaigns page actually works just fine like this but the dashboard hates me.

Edited by WillPJK
Update 8

Share this post


Link to post
Share on other sites

I'm so sorry for triple-posting but this is a necessary update and the edit feature on the last post has timed out.

I have figured out the four lines killing the whole page: 616 and 617, 654 and 655.

The contents of each pair of lines is identical:

$rsCampaigns = DBC::NewRecordSet($query);
$aCampaigns = $rsCampaigns->getAll(array('campaignid', 'clientid', 'campaignname', 'status', 'priority', 'revenue'));
	

Remove those four lines and everything except still the dashboard's 500 errors works. Well, so far it seems. I can at least confirm the file is no longer being deleted by the server. Something in that code is triggering a response and I don't know what.

Edited by WillPJK
formatting

Share this post


Link to post
Share on other sites

Okay, final update with working solution:

Just hours after figuring out the lines of code to remove (which literally took all night whoops) my host got back to me saying their antimalware was responsible for the problem and they'd fixed it.

So, for other people experiencing this problem:

Step 1) Contact your host explaining the issue and they will hopefully add the exception. My host is not a small host, so I suspect a few people might suddenly have the ability to create working installs now.

Step 2) If your host is crap or there isn't an antimalware problem, extract the Campaigns.php file from the installer ZIP, remove the four lines outlined in my previous post, and hopefully that will help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...