Jump to content

File Permission Error Detected Message


giantstep

Recommended Posts

I recently installed revive and users could not upload images, so I changed the image folder to 755 permissions and it works fine now but... Now this error message appears when users log in:

Screen_Shot_2017_02_08_at_11_33_15_AM.pn

Debug tail -f shows no message related to this. Is there a way to get rid of this? I'm assuming it is displaying because I changed the permissions on the image folder? What are the proper permissions that may be needed to get rid of this message?

 

Thanks

Edited by giantstep
Link to comment
Share on other sites

noone? hopefully someone can help. I just want to get rid of the error message. It looks bad and looks like I screwed something up. I do not think I did. 

Everything works fine... the error exists because I changed the permission of the var folder to 777 after the install (which is a new install/ not an upgrade). It would not upload any images until I changed var to 777, which is understandable. 

Link to comment
Share on other sites

Here are the list of all directories that Revive Adserver requires be set so that the webserver user can read/write to them.

Please note that these permissions must be set recursively, so that all files/subdirectories of these can also be read/written to by the webserver user.

 

revive-adserver/var
revive-adserver/var/cache
revive-adserver/var/plugins
revive-adserver/var/templates_compiled
revive-adserver/plugins
revive-adserver/www/admin/plugins
revive-adserver/www/images

Link to comment
Share on other sites

  • 2 weeks later...

Thanks Andre!

Sorry for the ignorant question but what permission do you recommend be set so the webserver can read/write to them? 777? 775? 755?

Also, if I need to recursively set the var to read write, how can I lock down the config file in /var/www.myserver.com.conf.php (from 777 to 644)

 

note: this is a fresh install on Digital Ocean. 

Edited by giantstep
Link to comment
Share on other sites

Hi @giantstep,

My personal preference is to:

  • chown -R [webserver_user]:[webserver_group] [directory]
  • chmod -R u+rw [directory]
  • chmod -R go-rw [directory]

So, set the directories to be owned by the user account that runs the webserver, then ensure that the owner (the webserver user) can read and write, but no-one else can (i.e. group, other).

If you want to prevent access to the config file, just:

  • chmod ugo-rw var/[domain].conf.php

So, remove read and write for the file for the user (owner), group, and other.

HTH.

Link to comment
Share on other sites

  • 3 weeks later...

This is what I have, more in my language...

My path is below, maybe this is the issue? The install is in a folder. 

Should I change the 755 permissions to 777 ??

 

revive-adserver/var/www/html/revive/var

 /var - 755        /www - 755        html/ -775       revive/  -775     

revive/var  -777
revive/var/cache  -777
revive/var/plugins  -777
revive/var/templates_compiled  -777
revive/plugins -755
revive/www/admin/plugins -755
revive/www/images -775

 

I should add here that everything works great. We have been using the adserver for two months with no issue. ...just getting the error message when people log in. So it appears permissions are good enough for it to work... Wish there was a log somewhere to know what is going on. 

Edited by giantstep
Link to comment
Share on other sites

I figured it out. It was showing up in the logs. It was just after the Maintenance task... I just had to look closer... it said unwritable file which was revive/plugin

I set all you listed above to 777 and no more error message!

Thanks for dealing with this. You guys are great and deal with a lot of slack from us amateurs! Kudos to ya!

 

 

 

Link to comment
Share on other sites

  • 1 year later...

I  am trying to install revive server on centos7 machine, while system pre-check  it is giving file permission error. I tried even changing the file permission to 777 with apache user (as i am running my web server under apache user ). After changing permission it is not taking changed permission same error again and again, no logs are generated anywhere. Please show me some path to debug and install it correctly.

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...