Jump to content

Running Revive with limited user and to Amazon RDS

Recommended Posts


We've been using Revive Adserver for two years with a client who's been having various issues, but we've managed to sort out most of them one way or the other.

Today we have performed a migration that broke Revive, and I've been digging into docs, forums, Stack Overflow for the past 6 hours without having any luck making it work. A bunch of questions coming below, really hope that someone can shed some light as the docs are 100% non-developer friendly.

We used to run Revive Adserver 3.1 and now one of the alternatives is trying to upgrade to 4.0.0. Here are some of the hacks I've tried - if even one of those works, we may be able to save the day.

1) Version 3.1 seems to rely on mysql_connect which is not available on the current system. Is there any safe way to replace just a part of 3.1 or a config parameter that works with mysqli?

2) Since we're running the database on Amazon RDS, there's no sock file available on our end which causes a problem with connecting to the remote server. Protocol is set to "tcp" and I've tried to comment out the socket argument in my ini/php file, but no luck. I can easily connect to the RDS with "mysql" from the shell, but socket port or mysql.sock seem to be required based on my error logs.

3) That said, is there any default configuration that I can look at? Some docs refer to a default.conf.php file in /var/ but the latest version includes none there.

4) Trying to install 4.0.0 instead also failed due to the same database permissions. Is there an easy way to override parts of 4.0.0 onto 3.1 and do the magic? 

There have also been issues with "session not writable", file permissions, incorrect path to the ini file that I managed to solve through the forums here, Stack Overflow or minor code adjustments, but I'm stuck with the rest of the process.

Thanks in advance.

Link to comment
Share on other sites

As a follow-up. I tried to install the latest version locally (on a LEMP stack running 50+ installs at the moment).

1) PHP sessions weren't working - that's a known issue so no biggie

2) Front-end was broken (undefined $ - assumingly jQuery conflicting with another library) - white page with black fonts alone

3) The database install created 2 database tables and it crashed with "Installation failed to create the core tables". 

That's on my local machine, local LEMP, root user for everything, MySQL set up properly and connecting to a local database as well.

Some help or documentation would be very much helpful if a clean install with a fresh download of 4.0.0 and a plain database faces 3 major issues before reaching a database population.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...