Jump to content
Michael Oeser

Issues with asyncronous JS tag

Recommended Posts

The first thing I would try is to make a very simple test page, with minimal or no HTML but just the async tag, and to upload it to your client's actual site/server. Then you can test if the tag will work on its own. It might be that something in the site is interfering with the tag.

Share this post


Link to post
Share on other sites

The main advantage of the async tag is that it is asynchronous. If the ad server is slow to respond, or not responding at all, using the async tag means that the webpage will appear regardless. That's why we developed the async tag. If you're comfortable about using a traditional javascript tag, by all means do so.

I am surprised, however, that the async tag isn't working, I don't see any reason why it doesn't, we've been using it for a very long time now on billions of ad impressions with great results.

Share this post


Link to post
Share on other sites

Yes, I can see that when I call your zone 6 with a traditional invocation code, I get a regular ad, but like you I do not see the async tag returning anything.

Did you generate this async tag fresh just now? Could you please make sure that it is the exact code that Revive Adserver generates?

I'm asking because this part:

data-revive-id="aa2d475d0af67de0182d07e1fd6902f1"

Is supposed to be a hash value of your ad delivery URL. If this hash and the URL http://adserver.automotiveit.eu/www/delivery/ do not match, the tag won't work.

Share this post


Link to post
Share on other sites

I regenerated the async and the traditional tags once again and added them to the testpage. Same result. how can I figure out if the hash matches my URL?

By the way: I took the same file and added it to my own site just to check and it shows nothing except the comments: https://der-prinz.de/adserver-test.html

Edited by Michael Oeser

Share this post


Link to post
Share on other sites

When I view that page on your own site, I see an ad for both tags:

2ads.jpg

But when I view it on the first site (http://www.automotiveit.eu/adserver-test.html) I only get an ad for the javascript tag (nr 2).

When you generate a zone's async invocation code inside your Revive Adserver UI, it will automatically calculate the correct has value.

Share this post


Link to post
Share on other sites

You are right. I can see them also on my site (had to deactivate my ad-blocker ;-))

Well then it seems as if something on my clients site blocks the async tag from displaying. Since we don´ seem to find a simple solution we will live with the traditional tag.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...