Jump to content
malmazan

Puzzling delivery and priorities

Recommended Posts

Hi all:

After many years with phpAdsNew (and a failed tryout of OpenX), I installed Revive 3.2.5 (don't have the PHP version for v4 just yet) from scratch for testing.

I have two 728x90px zones and two 240x400 zones, plus an e-mail zone and a zone I was planning to use with direct campaign invocation (which I have not found how to do on Revive yet).

I have about 15 advertisers and 20 contract campaigns, uncapped for the most part, plus a couple of remnant campaigns. I have checked that campaigns are correctly assigned to zones, and that contracted views and end dates are fine. I use normal JS invocation.

My web site shows about 10.000 impressions daily, and I've set tests for a few days that would serve 5% of contracted adviews and zone priorities are all wrong, with hardly any priorities assigned to contract campaigns. I tried also for about 8 hours to run 30% of views with similarly low priorities for contract campaigns even though remnants should be 0% (see attached image, a small number of contact banners have some priority, which can be 0.5%-12%), though stats showed mostly contract campaigns being delivered, albeit with very low views, about a third of what they should be. (Zone in this test is set not to show banners if the are none that can be show, though I have not seen this happen).

I have changed a few file delivery names and used re-directs in .htaccess.

I have checked the debug log and it seems fine, with maintenance running OK. I have checked the "Troubleshooting banner delivery" document. I know there was a command line way of showing some priority tables, but since the openx site is down and they are not documented I have not been able to run those tests.

I'd be very grateful for some advice. Thanks in advance.

priorities_728x90_.png

 

Edited by malmazan
wrong image

Share this post


Link to post
Share on other sites
17 minutes ago, andrewatfornax said:

Try for longer than 8 hours! Revive's model is to use information about past days to forecast inventory, so if it's a brand new install, 8 hours isn't enough. 

Let it run for a few weeks, and see how things go. :-)

I've tried several days. Although I can understand it can take days for an accurate prediction, I definitely cannot understand even for a very ballpark estimation.

Advertisers do not have weeks.

I started from stratch with revive v4 and just a zone, two campaigns (one contract and one remnant), and the one contract banner has a priority of 0.5% percent without any impressions yet.

Share this post


Link to post
Share on other sites

Hi @malmazan,

Glad to hear you got things working in the end. It turns out that I was wrong - it was actually a very long time ago that Revive Adserver used the idea of weekly cycles to predict upcoming inventory, and it took a couple of weeks for new zones to start working. These days, Revive Adserver only uses the last hour of delivery data to forecast upcoming inventory - so, provided maintenance is set up and running, then waiting a while won't make any difference to performance.

If you're still having issues, as you say, starting out with a simple setup with just a few campaigns and banners, and slowly adding more things over time, may help you figure out what's causing things to not work as you expect.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...