Jump to content

getting database error while upgrading to 4.0.0 from 3.2.2

Recommended Posts

Your database contains an old OpenX configuration table: rv_preferences. If you are trying to upgrade this database, please copy your existing configuration file into the var folder of this install. If you wish to proceed with a fresh installation, please either choose a new Table Prefix or a new Database.
here is the link to screen shot = GynLtMB.png
Edited by anshul123
Link to comment
Share on other sites

i have been trying this for 2 days now, Look like i have messed it up. because when i restored my old version i m not able to see stats now. So, i think i have to download and restart things all together again then. 

errormessage.gif An error occurred while accessing the database

Due to a problem with the database Revive Adserver couldn't retrieve or store data. If this problem is reproducable it might be caused by a bug in Revive Adserver. Please report the following information to the creators of Revive Adserver. Also try to describe the actions that led to this error as clearly as possible.

Version:    Revive Adserver v4.0.0
PHP/DB: PHP 5.6.26 / MySQL 5.5.52-cll
Page: /new/www/admin/install.php
Error: Duplicate entry 'anshul' for key 'rv_users_username'
INSERT INTO rv_users (contact_name , email_address , username , password , language , default_account_id , date_created , email_updated ) VALUES ('Administrator' , '[email protected]' , 'anshul' , '5916674c3da0acb7dd77ff84d46bd4bd' , 'en' ,  43 , '2016-10-08 13:34:33' , '2016-10-08 13:34:33' ) 
    [_qf__install-config-form] => 
    [action] => configuration
    [moreFieldsShown] => 1
    [previousPath] => /home/kaleidomedia/public_html/traffic
    [adminName] => anshul
    [adminPassword] => ***********
    [adminPassword2] => ************
    [adminEmail] => [email protected]
    [adminLanguage] => en
    [prefsTimezone] => CST6CDT
    [webpathAdmin] => traffic.kaleidomedia.com/www/admin
    [webpathDelivery] => traffic.kaleidomedia.com/www/delivery
    [webpathImages] => traffic.kaleidomedia.com/www/images
    [webpathDeliverySSL] => traffic.kaleidomedia.com/www/delivery
    [webpathImagesSSL] => traffic.kaleidomedia.com/www/images
    [storeWebDir] => /home/kaleidomedia/public_html/traffic/www/images
    [save] => Continue »

now issue is when i do restore back up.. i see this in my product update

You are currently using Revive Adserver v3.2.2 (warning: database is stamped as v4.0.0) running on Apache 2.4.23, PHP 5.6.26 and MySQL 5.5.52-cll.


info.gif   Your version of Revive Adserver is up-to-date. There are currently no updates available.


Edited by anshul123
removing password
Link to comment
Share on other sites

  • 2 weeks later...

I'm having the same error as originally posted by the OP. Revive doesn't seem to notice this is an upgrade, even though I have thoroughly followed the instructions. This error goes away when I copy the default.conf.php (as suggested in another topic), but when I do this, I get the second error posted here.

Link to comment
Share on other sites

I have repeated the upgrade steps for a fourth time, but it's not working: the first two times I tried, I got the same "INSTALLING Revive Adserver 4.0.0" message (I guess it should say "UPGRADING" or something similar?). Now I'm getting a message suggesting Revive 4 has been detected and is working, but of course it's not:

Detected Revive Adserver 4.0.0
Revive Adserver is up to date

Your Revive Adserver database and file structure are both using the most recent version and therefore no upgrade is required at this time. Please click Continue to proceed to the administration panel.

As I said previously, I'm using the exact same domain.

This is what I'm doing:

I have a copy of my database "revive3" named "revive4". Username "revive" has been granted all privileges on revive4 (and continues to have all privileges on old revive3).

Step 1: I upload all files to a new folder (domain.com/adserver_new)
Step 2: I change permissions to files and folders
Step 3: I upload the config file, changing the database name with the name of the database I copied previously (revive4)
Step 4: I try to run the upgrade wizard at domain.com/adserver_new but instead of an UPGRADE message I get an INSTALLATION message...

Please help!

Link to comment
Share on other sites

Yes, if the upgrade wizard detects the configuration files from the previous version, it will start by saying "Upgrading to Revive Aderver v4.0.0" (or whatever version you're going towards).

My best guess is that when you copied the configuration file(s), in their new location the permissions and/or owner prevent the webserver from seeing them. I recommend checking that.

Link to comment
Share on other sites

Hello Erik, thank you for your reply. The only permissions I'm touching are the ones mentioned on the tutorial:

  • ‘adserver_new/plugins’
  • ‘adserver_new/var’
  • ‘adserver_new/www/admin/plugins’

Should I change other permissions that are not mentioned here (besides the images folder which is outside of the installation)?

You also mention the configuration file(s) as if there's more than one configuration file that I have to copy. The only configuration file that I copied is the domain.com.conf.php in the /adserver/var/ making sure I changed the name of the database to the new one "revive4". It's permission is set to 644. Is that the correct permission and is there another configuration file that I have to check?


Link to comment
Share on other sites

I mentioned configurations files in plural, only for completeness. For people who use Revive Adserver with a different URL for the ad management UI and the ad delivery component, they will have more than one file. This is not covered in the upgrade instructions since there will be very many variations, and we wanted to keep the instructions as concise as possible for novice users or people with less technical skills and/or experience.

Permission for the config file should be set according to what it was in the "old" folder. In addition to the permissions, make sure that the file can be accessed by the webserver software.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...