Jump to content
Reyes

Geotargeting and MaxMind .dat files

Recommended Posts

Hi,

I am trying to set the geo city with maxmind, i put the .dat files in the server and set the path to that files, in plugin->detalis->settings, but i am getting this warning message.

   
warning.gifWARNING: The delivery engine limitations DO NOT AGREE with the limitations shown below
Please hit save changes to update the delivery engine's rules

and i do not see the Geo - Country / City option in the  icon-acl-add.gif Add delivery limitation:  Client - BrowserClient - DomainClient - IP addressClient - LanguageClient - Operating systemClient - UseragentSite - ChannelSite - Page URLSite - Referring PageSite - SourceSite - VariableTime - DateTime - Day of weekTime - Hour of day 

what could it be the reason??

 

Edited by Erik Geurts
Topic title edited to help others find it in the future

Share this post


Link to post
Share on other sites
13 minutes ago, dJAX said:

Hi Reyes,

just enable geo option..Configuration => Geo targeting settings => check "Show geotargeting delivery limitations even if GeoIP data unavailable"  you can enable "MaxMind GeoIP (Flat file)".

This recommendation is incorrect. It should not be needed to set that "Even if GeoIP data unavailable checkbox" on, in fact, it is advised to never do that unless you know exactly what you're doing.

 

12 hours ago, Reyes said:

set the path to that files

I recommend double checking that path, and to make sure that the folder and the files in it are actually accessible.

Share this post


Link to post
Share on other sites

Hi folks,

Sorry to re-open a resolved thread, but I'm having the same difficulty. I've downloaded the latest GeoLiteCity.dat file from here: http://dev.maxmind.com/geoip/legacy/geolite/?rId=revive, I've uploaded it to the same location as the "GeoIP.dat" file ([document root]/plugins/geoTargeting/oxMaxMindGeoIP/data/) and referenced it in the "Path to geoipCityLocation file" section of the plugin settings with the full path, and I've made sure that the permissions are the same on both files (owned by the webserver user) but I'm still not seeing a "Geo - City" option in my delivery options. I've even tried renaming the file to GeoIPCity.dat as suggested here (http://dev.maxmind.com/geoip/legacy/install/city/). It *seems* that Revive is seeing the new file because the "Geo - Lat/Long" option appears when I have that file specified in the settings whereas I don't get the option when it's not there. Any thoughts as to what I might check next?

Thanks!
Reid

Share this post


Link to post
Share on other sites

@Reid We had a very similar case yesterday. It was the same file, downloaded from that same location you mentioned on Tuesday of this week. We downloaded it again today (and it had changed since Tuesday, surprisingly). Once uploaded on the server, geotargeting started working again.

My two cents: somehow the file you found earlier on maxmind.com was wrong, and it was corrected after they found out.

Share this post


Link to post
Share on other sites

Hello,

Newbie here. I have searched the forum and the internet but couldn't find something to solve my issue.

icon-acl-add.gif Add delivery limitation:  NO option here for banner geo limitation.

I am trying to use GeoIP.dat and GeoLiteCity.dat files

Plugin is enabled, Geotargeting Module Type is set to Maxmind GeoIP flat file,

paths are set to [document root] / plugins/geoTargeting/oxMaxMindGeoIP/data

Is there anything special for https sites?

I have tried renaming the dat files, checked the file permissions on the server (all 777).

Any ideas or suggestions?

Thanks,

John

Share this post


Link to post
Share on other sites

@Erik Geurts

Hey thanks for the reply!

My paths are set to the files and not the folders and i  have nothing at  icon-acl-add.gif Add delivery limitation:

/plugins/geoTargeting/oxMaxMindGeoIP/data/GeoIP.dat

I could not find a solution and i start to think that there is a problem with the dat files.

Any other ideas? 

Thanks,

John

Share this post


Link to post
Share on other sites

@Erik Geurts

Hello again.

[document root] / plugins/geoTargeting/oxMaxMindGeoIP/data/GeoIP.dat

is what i am using. i mentioned it on a previous post sorry about that. (var/.....)

Besides the path what else do you believe that might be causing the adserver not to be able to load the files?

Thanks,

John

Share this post


Link to post
Share on other sites

SOLVED after all!!!

It might seem stupid but i started from scratch and:

Installed all the default plugins.

Guess what. It worked. Delivery limitations, cacheStore, Delivery long etc.

Thanks again for your time!!!

Best regards john

 

 

Share this post


Link to post
Share on other sites

I would recommend to put the MaxMind files in their own folder somewhere on the server outside of the Revive Adserver folders. That way when you perform an upgrade in the future, these MaxMind files will not be affected and geotargeting will continue to work. 

See http://www.reviveconsultant.com/articles/choosing-a-smart-location-for-a-revive-adserver-installation/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...