Jump to content

Stats not showing after upgrade to 3.2.4

Recommended Posts

After upgrading to version 3.2.4, the statistics added since the time of the upgrade are not showing in the user interface. 

In reading through the forum, I believe the issue is with the plugins, however after the upgrade, I was unable to delete or disable the plug-ins to test.  I am getting the following message: File not found Failed to parse the plugin definitions contained in package openXVideoAds 

After checking, I found the plugins had not been installed, so I tried to install them, however could not - received this message:
Plugin with this name is already installed openX3rdPartyServers 
The uploaded file did not pass security check 
The uploaded file openX3rdPartyServers.zip was not unpacked 

I then tried to copy the files from the previous install into the new install, that didn't work either: still receiving the same message:
File not found Failed to parse the plugin definitions contained in package openXVideoAds.

Then did a clean install, the plugins did not install, so installed them manually and activated them.  Tied this install into the upgraded database, same result.  I am able to see stats previous to the upgrade, but nothing is showing since the upgrade. 

Automatic maintenance is running correctly.

Database is collecting the stats on the days AFTER the update, don't see anything before the update.

User Interface Preferences are set up correctly.

I'm sure I'm missing something, just not sure what to do next.....

Thanks in advance for any help.

Link to comment
Share on other sites

I've had the same experience with a number of upgrades. I also found that the issue was the plug-ins.

I wish I had recorded the steps to fix the issue but my memory is that you need to:

  1. download the latest version of the plug-ins (I always had a tough time finding them)
  2. delete the old ones
  3. install the new ones
  4. set permissions
  5. check that they are OK within the Admin area

My memory is that it is not a fun process and the server is not running properly until you get it fixed so there's lots of pressure to fix it.

Whatever causes this problem, it would be great to have it addressed by the developers.

Link to comment
Share on other sites

Thanks for your reply - 

This was a clean install, so I'm not sure why the plugins didn't install with the installation as they are supposed to.
I used the plugins from the latest version, so I'm assuming these are truly the 'latest'. Couldn't find anything anywhere else.
Permissions are OK
Everything looks good in the Admin area...

You're right, it isn't fun, and the ad-server is pretty much useless if we can't pull the stats for our clients.
It would be nice to have an explanation/ solution as I've seen quite a few posts concerning the problem, but no real solutions.

Hoping someone else has some ideas.

Link to comment
Share on other sites

4 hours ago, westwindweb said:

This was a clean install

You started the topic by saying it didn't work after an upgrade, and now you say it's a clean install. Forgive me, but that's all very confusing.

If you do an upgrade according to the upgrade instructions, all plugins will be migrated along and there shouldn't be any issue with statistics. Instructions can be found here:


That process works, I have personally done it over 2,500 times by now.

Link to comment
Share on other sites

To be clear, I did both the upgrade and a clean install. As I said in my original post, after trying the upgrade process (twice actually) as described in the upgrade instructions, which I followed, and then searching through the forums and other documentation, I did a clean install so I would have something to compare the upgrade to, hoping to maybe find a solution.

I have used this ad server for many years, and upgraded many times, so I'm not new to the process.  However, this time is different, and when I see others with the same problem and no solutions, nor can I seem to find a solution anywhere after hours of searching, I thought I might find an answer by posting a request for help. 

The plugins didn't install correctly - not in the upgrade process nor in the clean install. I'm not the only one having this problem. I certainly may have done something wrong - not saying I didn't - I would just really like some help in understanding why this is happening and in finding a solution. I think it would help quite a few of us...

Link to comment
Share on other sites

Tried the upgrade process once more.   In step 3, when the process asks for the path to the previous installed version, the process begins to try to install the plugins, and each plugin fails, and finally I receive the InstallNonBlockingErrors in step 4.

Once the folders are renamed, and I log in and go to the plug-ins, I receive the following error messages, even though the files are there:

Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openXVideoAds.xml 
Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openXDeliveryLog.xml 
Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openXInvocationTags.xml 
Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openXMaxMindGeoIP.xml 
Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openXDeliveryCacheStore.xml 
Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openXReports.xml 
Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openX3rdPartyServers.xml 
Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openXDeliveryLimitations.xml 
Failed to find package definition file /home/xxx/public_html/xxx/plugins/etc/openXBannerTypes.xml 

At this point I cannot disable or uninstall these plug-ins, so I'm unable to install the new ones.

Thanks in advance for help



Link to comment
Share on other sites

OK, so the issue is not that the stats are not showing (topic title) but that there is a problem during the upgrade process. Let's focus on that.

If you see that the plugins aren't getting migrated during the upgrade, there is no point in continuing, that issue needs to be resolved first.

Unfortunately, it's impossible to say anything about the cause without access to the specific server. Note: do not post your server details in public.

Link to comment
Share on other sites

  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...