Jump to content
Mohammed Badran

XML error: Invalid document end at line 1

Recommended Posts

Hello,

I am working on Revive ad server system and i was able to create API to fetch all required data from revive, i installed pear with xml_rpc2 library to make the connection and it is working fine locally on my local host, now when i tried to connect to Revive system on the client side using the 'HTTPS' protocol it gives me the following error :

Warning! : (Revive AdServer) Exception #105 : XML error: Invalid document end at line 1

i am using the following code :

XML_RPC2_Client::create( 'https:// the link /www/api/v2/xmlrpc/', options array );

ps: i changed the option 'sslverify' to false inside options array

can anybody tell me how to fix this issue? again i was able to make the connection locally and it is working fine, also on test account with 'http' working fine, but with 'https' domain it is not working, is it something required on the server? or missing from my side? or something else?

Thank you very much.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...