Jump to content
BaliDave

Upgrade Problem For Www Vs No-Www

Recommended Posts

When I upgraded from OpenX 2.6.5 to RA 3.0.2, I ran into a problem concerning using www.example.com vs example.com.  Previously I had my config file named like example.com.conf.php.  Renaming it to www.example.com.conf.php seemed to fix the problem, since the upgrade was able to finish.

 

HOWEVER, the ad links no longer work (I allow RA to modify links for tracking) -- they give me a 404 Not Found.  The generated links all begin with example.com/.   But if the generated links were to have www.example.com at the front, they work.  So I changed several lines in my config file (admin=, delivery=, deliverySSL=, images=, and imagesSSL=) to now start with www.example.com instead of example.com.  Before it wasn't clear I needed to do such.

 

Well that change made my links now "work" -- they take you to the right place.  BUT now all my targeting channels are broken.  So links intended only for a few pages are being shown on ALL pages where they possibly might, i.e. the targeting channels I'm using for them are being ignored.  So I went to Targeting Channels section and get the message

 

"warning.gifWARNING: The delivery engine limitations DO NOT AGREE with the limitations shown below
Please hit save changes to update the delivery engine's rules
"

 

for all my channels.  And now there are NO options available in the "Add delivery limitations" drop-down.  So I can't individually fix the channels.

 

Any suggestions on what I can do to recover from this?  I guess I could redo the upgrade, but then lose not only stats, but all changes I made to RA since (new and changed ads).  I tried a few things, but either get one problem or the other.

Share this post


Link to post
Share on other sites

If "www.example.com" if your "primary" domain, your config file "www.example.com.conf.php" should be the one with all the details in it.

 

However, there should also be one called "default.comf.php" that has contents something like:

;<?php exit; ?>
;*** DO NOT REMOVE THE LINE ABOVE ***
realConfig="www.example.com"

Do you have one of these?

Share this post


Link to post
Share on other sites

I came across this thread via the error message "WARNING: The delivery engine limitations DO NOT AGREE with the limitations shown below

Please hit save changes to update the delivery engine's rules".
I also upgraded to AdServer from a previous OpenX version.
 
I managed to locate the default.conf.php and indeed, I had the old path in there.
However, changing this didn't make the delivery limitations work. Do you have any other idea how I could make this work and get the 'add delivery limitations' dropdown to populate?
 
Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...