Jump to content
aidangig

Revive Adserver 3.1.0 changed root directory but get this...

Recommended Posts

Hey,

 

I was trying to change the root directory for revive-adserver 3.1.0., and I did. I went under the admin. And changed the ad server URL deliveries to the new directory, but it get an error message everytime I login.

Error says "Error: File permission errors detected."

Is this normal? How can I remove this? It serves the ads fine, but will they track properly?

Share this post


Link to post
Share on other sites

In the var directory for revive you will find a file called mydomain.com.conf.php where "mydomain.com" will be your domain name.

This file must be writable by the webserver in order to change the settings via the revive admin.

If your webserver is running as user nobody, then the file will need '666'

If your webserver is running as the account owner, the default 644 should be fine.

You could also edit this file using nano from a shell if you feel confident. Always make a backup of any file before you change it just in case...

The developer recommends that the config file be set so that it is not writable by the webserver after you have finished making your changes for security reasons. Check the install guide for details...

Edited by vicos

Share this post


Link to post
Share on other sites

In the var directory for revive you will find a file called mydomain.com.conf.php where "mydomain.com" will be your domain name.

This file must be writable by the webserver in order to change the settings via the revive admin.

If your webserver is running as user nobody, then the file will need '666'

If your webserver is running as the account owner, the default 644 should be fine.

You could also edit this file using nano from a shell if you feel confident. Always make a backup of any file before you change it just in case...

The developer recommends that the config file be set so that it is not writable by the webserver after you have finished making your changes for security reasons. Check the install guide for details...

Sorry. Still gives me the same error once you login as a regular user. What do I do now?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...