Jump to content

Unable to upgrade from 3.2.0 to 3.2.1

Recommended Posts

I am not able to upgrade from 3.2.0 to 3.2.1 and I have no idea what is wrong. I tried for the third time in the span of couple of weeks with the same result.

I followed the official instructions step by step: http://www.revive-adserver.com/support/upgrading/

The problem comes when I run the upgrade wizard in the browser. It is asking me for database details instead of picking them up from the config file. When I enter the details it is not happy.

I have successfully upgraded Revive couple of times before, even when it was still OpenX. I am out of ideas here. Can somebody please help me?

This is in the install.log:

Attempting to detect an existing Openads (aka. phpAdsNew) installation...
PAN not detected
Attempting to detect an existing Openads (aka. Max Media Manager 0.1) installation...
MMM v0.1 not detected
Attempting to detect an existing Openads (aka. Max Media Manager 0.3) installation...
MMM v0.3 not detected
Attempting to detect an existing Revive Adserver installation...
No previous version of Revive Adserver detected
Link to comment
Share on other sites

I believe it relies upon your config file to determine if it is an existing installation. i.e. does the config file exist and does it have an existing database specified in the parameters.

the config file is in the 'var' directory: yourdomain.com.conf.php where "yourdomain.com" is your domain name.

Maybe you overwrote this when you uploaded the new files...

Also, if you originally accessed the domain as mydomain.com and are trying the upgrade via www.mydomain.com, this might cause it to look for a differently named config file from the one that exists.

Edited by vicos
Link to comment
Share on other sites

No, I definitely didn't overwrite the config file. It has the correct file name. I am very detail oriented person which is kind of a necessity when performing upgrades such as this one. I thought it might be file permission or something else at the system level, but I can't figure it out. I even started debugging the PHP code that is determining if the action that needs to be done is an upgrade or an install. No luck there either. Has anyone got any other ideas? Somebody from the Revive team?

Link to comment
Share on other sites

The permissions on the file are 100% correct. It still doesn't work as it should.

when you say "100% correct", it might be an idea to post a screenshot of the file permissions, so that people (admins) can have an opportunity to suggest alternative possible reasons for failure. "It doesn't work" and "as it should" also doesn't help diagnose the problem, at all. The more information you can dig out, for people to look at, the more likely it is that someone can help you. NB. this is just a suggestion as more info. is always better than less...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...