Jump to content

Revive Upgrade Showing Install Screen

Recommended Posts

I am attempting to upgrade my openx v.2.8.10 to Revive 3.0.2


I have followed all the upgrade instructions, but when I try to finally run the upgrade, I get the Revive installation screen and I am asked from db details.

Is there a step missing in the upgrade instructions to make The revive installer recognize that it is performing an upgrade?

if openx was using table prefix ox_ then must I use ox_ in the installation instead of rv_?


Just guessing here.  Need help.


Link to comment
Share on other sites

It looks like you either forgot to copy the config file from the 'old' to the 'new' var folder, or you edited the config file incorrectly.


If you are upgrading from OpenX Source to Revive Adserver, the table name prefix is probably ox_, and you need to leave it like that. If you change it to rv_, the upgrade wizard won't find your existing tables, and thus assume it is a new installation.

Link to comment
Share on other sites

Its like the installer doesn't see my config file.

I edited the config file with the new db details (dbname, user, password) in windows notepad.
Must I edit anything else in the config file?  any of the paths?

These are the lines I changed (with ******s):

Link to comment
Share on other sites

Think I might be missing a very importent step when upgrading from openx to revive.


Do I first need to do a fresh install of revive in "adserver-new" (according to guide).  And once the installation is complete, then replace the config file to point to an old copy of the openxdb, and then when I browse to "adserver-new" I will get the upgrade screen?

Link to comment
Share on other sites

If you have already got to a certain point of previously installing (rather than upgrading) Revive Adserver, it may be that the Revive Adserver installation is no longer configured in the default state to allow an upgrade to happen.


I would remove your Revive Adserver installation (assuming you have not changed over to using it yet), and start again with a fresh un-zip of the install package, and make sure you copy over your OpenX config files (*.conf.php) from the old OpenX var directory to the new Revive Adserver var directory, before you start. It should then do an upgrade, instead of an install.


Don't be confused by the config files in any etc directories! They are for new installations only, so leave them well alone.

Link to comment
Share on other sites

  • 2 weeks later...

Found the issue!!


I was following the upgrade instructions so carefully I didn't notice that when I went to WWW.mydomain.com/adserver_new, it actually automatically redirected to the non WWW url http://mydomain/adserver_new.....

but my conf file was named www.mydomain...... and was thus being ignored.  As soon as I removed the "www" from the beginning of my conf file the upgrade screen came up instead of the install screen. 

Why does the install redirect automatically to the non WWW version ??????? 

This drove me insane for weeks!

But now when I click agree on the first screen, I get a 500 Internal error.


Steps I did:

1: upload revive 3.0.2 to a new folder called "adserver_new"

2: made a copy of the openx database.

3: downloaded the openx conf.php file edited it in notepad with the new copied database connection details (dbname,user,password).

4: uploaded the edited conf.php file to adserver_new/var

5: browsed to folder "adserver_new" got the upgrade screen.  Clicked "I agree" .    get to "http://mydomain.com/adserver_new/www/admin/install.php?action=check" with "500 Internal Server Error".


What did I do wrong?

Link to comment
Share on other sites

My host says they have a maintained version of php 5.4.4 where they fix bugs.

Anyway.  I tried a fresh installation and when I look at the errors during Revive installation it looks like Revive is trying to install openX.... plugins?  


1 example:

  • Installation of plugin 'openXVideoAds' failed:
    1. Server returned: 500 Internal Server Error

Also there is a "UPGRADE" blank file in the "var" folder.  But I'm doing a fresh install.  Will this "UPGRADE" file be a problem?  I tried deleting it but then the Install won't run at all.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...