Jump to content
gabrielt

Error Message After Server Move

Recommended Posts

Hi,

 

Moved my Revive Adserver installation to a new server, and we are seeing the following errors:

 

MESSAGE: Redefining already defined constructor for class XML_Parser
TYPE: Strict
FILE: /www/hsads/lib/pear/XML/Parser.php
LINE: 204
DEBUG INFO:
 
199 * @param string $mode how this parser object should work, "event" for 
200 * startelement/endelement-type events, "func" 
201 * to have it call functions named after elements 
202 * @param string $tgenc a valid target encoding 
203 */ 
204 function __construct($srcenc = null, $mode = 'event', $tgtenc = null)
 
205 { 
206 parent::__construct('XML_Parser_Error'); 
207 
208 $this->mode = $mode; 
209 $this->srcenc = $srcenc;
MESSAGE: Non-static method Date_TimeZone::isValidID() should not be called statically
TYPE: Strict
FILE: /www/hsads/lib/pear/Date/TimeZone.php
LINE: 3642
DEBUG INFO:
 
3637 Date_TimeZone::setDefault($_DATE_TIMEZONE_DEFAULT); 
3638 } elseif (getenv('PHP_TZ') && Date_TimeZone::isValidID(getenv('PHP_TZ'))) { 
3639 Date_TimeZone::setDefault(getenv('PHP_TZ')); 
3640 } elseif (getenv('TZ') && Date_TimeZone::isValidID(getenv('TZ'))) { 
3641 Date_TimeZone::setDefault(getenv('TZ')); 
3642 } elseif (Date_TimeZone::isValidID(date('T'))) {
 
3643 Date_TimeZone::setDefault(date('T')); 
3644 } else { 
3645 Date_TimeZone::setDefault('UTC'); 
3646 } 
3647 //
MESSAGE: Non-static method Date_TimeZone::setDefault() should not be called statically
TYPE: Strict
FILE: /www/hsads/lib/pear/Date/TimeZone.php
LINE: 3645
DEBUG INFO:
 
3640 } elseif (getenv('TZ') && Date_TimeZone::isValidID(getenv('TZ'))) { 
3641 Date_TimeZone::setDefault(getenv('TZ')); 
3642 } elseif (Date_TimeZone::isValidID(date('T'))) { 
3643 Date_TimeZone::setDefault(date('T')); 
3644 } else { 
3645 Date_TimeZone::setDefault('UTC');
 
3646 } 
3647 // 
3648 // END 
3649 ?> 
3650
MESSAGE: Non-static method Date_TimeZone::isValidID() should not be called statically
TYPE: Strict
FILE: /www/hsads/lib/pear/Date/TimeZone.php
LINE: 153
DEBUG INFO:
 
148 * @param string $id the time zone id to use 
149 */ 
150 function setDefault($id) 
151 { 
152 global $_DATE_TIMEZONE_DEFAULT; 
153 if(Date_TimeZone::isValidID($id)) {
 
154 $_DATE_TIMEZONE_DEFAULT = $id; 
155 } 
156 } 
157 
158 /**
MESSAGE: Non-static method Language_Loader::load() should not be called statically
TYPE: Strict
FILE: /www/hsads/lib/OX/Extension/authentication/authentication.php
LINE: 18
DEBUG INFO:
 
13 require_once MAX_PATH . '/lib/max/Plugin/Translation.php'; 
14 require_once LIB_PATH . '/Plugin/Component.php'; 
15 require_once 'Date.php'; 
16 require_once MAX_PATH . '/lib/max/language/Loader.php'; 
17 
18 Language_Loader::load('settings');
 
19 
20 /** 
21 * Plugins_Authentication is an parent class for Authentication plugins 
22 * 
23 * @package OpenXPlugin
MESSAGE: Undefined index: action
TYPE: Notice
FILE: /www/hsads/lib/OX/Admin/UI/Install/InstallController.php
LINE: 80
DEBUG INFO:
 
75 * Called before any action gets executed 
76 */ 
77 protected function init() 
78 { 
79 // No upgrade file? No installer! Unless the user is in the last step 
80 if (!file_exists(MAX_PATH . '/var/UPGRADE') && 'finish' != $_REQUEST['action']) {
 
81 header("Location: index.php"); 
82 exit(); 
83 } 
84 @set_time_limit(0); 
85
MESSAGE: Cannot modify header information - headers already sent by (output started at /www/hsads/lib/max/ErrorHandler.php:130)
TYPE: Warning
FILE: /www/hsads/lib/OX/Admin/UI/Install/InstallController.php
LINE: 81
DEBUG INFO:
 
76 */ 
77 protected function init() 
78 { 
79 // No upgrade file? No installer! Unless the user is in the last step 
80 if (!file_exists(MAX_PATH . '/var/UPGRADE') && 'finish' != $_REQUEST['action']) { 
81 header("Location: index.php");
 
82 exit(); 
83 } 
84 @set_time_limit(0); 
85 
86 // load translations for installer

Share this post


Link to post
Share on other sites

Edit: I've just noticed that when trying to open the adserver, it redirects me to /www/admin/install.php, so it thinks it is not installed. Probably a flag somewhere that I need to fix... Note: INSTALLED is present at /var

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...