Jump to content

Problems With Upgrade To Revive 3.0.2 From Openx 2.5.8


Recommended Posts

Over the weekend I tried to upgrade from openx 3.8.5 to revive 3.0.2. 


  1. I can confirm that openx3.8.5 is exploitable as reported in 3.8.10.  Ours is exploited and triggers message from AVAST.
  2. I followed your upgrade instructions for revive.  When I was running the upgrade wizard, I got the following in step 4(I believe, second to last step in the wizard)


One or more plugin files couln't be located, check the install.log file for more information

Here is install.log message


Starting file-check for plugins...

Plugin: openXVideoAds - Unable to locate file: /home/httpd/html/admin/tools/openx-2.8.5/www/adm


Finished file-check for plugins



I went to look for this file and found it at:

Plugin: openXVideoAds - Unable to locate file: /home/httpd/html/admin/tools/openx-2.8.5/www/adm



note that in my install of 3.8.5 the plugins are at /www/admin/plugins rather than /www/admin/extensions where the upgrade wizard is looking for the file and failing to find it.


  1. I looked around for a while but didn’t know what to do about the error in #2.  Eventually, I told the wizard to ‘continue’.  It completed and took me to the admin panel for revive.  Later, I decided to redo the install so I deleted the database I had put at revive_302 and recopied the openx_385 db to revive_302.  When I tried to run the update wizard, it redirects me to the revive admin panel, but throws the same error message in the install.log file:


[root@web var]# tail -f install.log

Plugin: openXMaxMindGeoIP - Unable to locate XML files

Plugin: openXInvocationTags - Unable to locate XML files

Plugin: openXDeliveryLog - Unable to locate XML files

Plugin: openXMarket - Unable to locate XML files

Plugin: openXWorkflow - Unable to locate XML files

Plugin: openXVideoAds - Unable to locate XML files

Finished file-check for plugins

Starting file-check for plugins...

Plugin: openXVideoAds - Unable to locate file: /home/httpd/html/admin/tools/openx-


Finished file-check for plugins


How can I complete the update wizard?  Is it running?  Of course now since so much time has passed, I will have to delete and recopy the database to start again. What do I need to do to correct the plugin error?

Link to comment
Share on other sites

  • 2 weeks later...

I think others have reported that to get the upgrade to proceed, simply create an empty file in the location(s) that the upgrade wizard is requesting. 


I would think that, at best, this file then gets replaced when the plugin is upgraded to a later version (I am pretty sure all plugins have now been updated to some degree in Revive Adserver), or, at worst, the empty file you create gets copied into the new Revive Adserver installation, but as an empty file, it can't introduce any new exploit and won't add any missing features that you're not already missing as a result of the file being absent.


Please note, however, that as you've mentioned old exploits from OpenX, upgrading to Revive can't deal with your server if you've been compromised - you still need to manually clean up all compromised data in your database, remove any users that are not ones that should be there and ideally change all your passwords manually.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...