Jump to content
Hawk

Upgrade From Openx 2.8.10 To Revive 3.0.5 Not Working

Recommended Posts

Hello,

 

I am trying to do an upgrade of OpenX 2.8.10 installation to Revive 3.0.5, however, I'm getting some errors on System Check part.

OpenX 2.8.10 is a default installation without any additional plugins, so I'm not getting why is the system alerting that database is not correct.

 

System check

The install wizard perfomed a check of your web server settings to ensure that the installation process can complete successfully.
Please check any highlighted issues to complete the installation process.

Configuration of your webserver does not meet the requirements of the Revive Adserver.
In order to proceed with installation, please fix all errors. For help, please see our documentation
and FAQs

  • Show detailed system check Previous version - 1 error
    • Errors were found when detecting previous installations of Revive Adserver
      We have detected integrity issues with your database. This means that the layout of your database differs from what we expect it to be. This could be due to customization of your database.

Check name

Current value

Status

application

  1. - database integrity check detected problems with the database
  2. - 2 indexes to remove
  3. - 2 indexes to add

NOT OK

 

 

This is the output in changes_tables_core_613.xml which was created after the attempt of upgrade:

<?xml version="1.0" encoding="ISO-8859-1" ?>
<?xml-stylesheet type="text/xsl" href="xsl/mdb2_schema.xsl"?>
<instructionset>
  <name></name>
  <version></version>
  <comments></comments>
  <constructive>
    <changeset>
      <name></name>
      <version></version>
      <change>
        <table>
          <name>data_intermediate_ad_variable_value</name>
        <index>
          <add>
            <name>data_intermediate_ad_con</name>
            <was>data_intermediate_ad_con</was>
            <indexfield>
              <name>data_intermediate_ad_connection_id</name>
              <sorting>ascending</sorting>
            </indexfield>
          </add>
        </index>
        <index>
          <remove>
            <name>data_intermediate_ad_</name>
        </remove>
      </index>
    </table>
      <table>
        <name>data_summary_zone_impression_history</name>
      <index>
        <add>
          <name>operation_interval_id</name>
          <was>operation_interval_id</was>
          <indexfield>
            <name>operation_interval_id</name>
            <sorting>ascending</sorting>
          </indexfield>
        </add>
      </index>
      <index>
        <remove>
          <name>operation_interval_i</name>
      </remove>
    </index>
  </table>
</change>
</changeset>
</constructive>
<destructive>
  <changeset>
    <name></name>
    <version></version>
    <remove>
      <table>banner_vast_element</table>
        <table>data_bkt_a</table>
          <table>data_bkt_a_var</table>
            <table>data_bkt_c</table>
              <table>data_bkt_m</table>
                <table>data_bkt_r</table>
                  <table>data_bkt_vast_e</table>
                    <table>database_action</table>
                      <table>ext_market_advertiser</table>
                        <table>ext_market_assoc_data</table>
                          <table>ext_market_campaign_pref</table>
                            <table>ext_market_general_pref</table>
                              <table>ext_market_plugin_variable</table>
                                <table>ext_market_setting</table>
                                  <table>ext_market_stats</table>
                                    <table>ext_market_web_stats</table>
                                      <table>ext_market_website_pref</table>
                                        <table>stats_vast</table>
                                          <table>upgrade_action</table>
                                        </remove>
                                      </changeset>
                                    </destructive>
                                  </instructionset>

In this part I already see few strange things. First, I don't have a table data_intermediate_ad_, I have data_intermediate_ad_connection (which system wants me to add).

With all rest stated in log is the same thing, I have a feeling that revive doesn't know how to get the name of the table correctly, really not sure, because everything is there, it just doesn't recognize it.

 

 

This is an output from install.log

 

=========================================================================
Attempting to detect an existing Openads (aka. phpAdsNew) installation...
PAN not detected
Attempting to detect an existing Openads (aka. Max Media Manager 0.1) installation...
MMM v0.1 not detected
Attempting to detect an existing Openads (aka. Max Media Manager 0.3) installation...
MMM v0.3 not detected
Attempting to detect an existing Revive Adserver installation...
schema file found: /home/****/public_html/ads/revive-305/etc/changes/schema_tables_core_613.xml
schema definition from cache TRUE
successfully parsed the schema
schema name: openads
schema version: 613
schema status: final
running integrity check
comparing database **** with schema /home/****/public_html/ads/revive-305/etc/changes/schema_tables_core_613.xml
index missing from table: data_intermediate_ad_variable_value.data_intermediate_ad_con
index missing from table: data_summary_zone_impression_history.operation_interval_id
table is not part of schema: banner_vast_element
table is not part of schema: data_bkt_a
table is not part of schema: data_bkt_a_var
table is not part of schema: data_bkt_c
table is not part of schema: data_bkt_m
table is not part of schema: data_bkt_r
table is not part of schema: data_bkt_vast_e
table is not part of schema: database_action
table is not part of schema: ext_market_advertiser
table is not part of schema: ext_market_assoc_data
table is not part of schema: ext_market_campaign_pref
table is not part of schema: ext_market_general_pref
table is not part of schema: ext_market_plugin_variable
table is not part of schema: ext_market_setting
table is not part of schema: ext_market_stats
table is not part of schema: ext_market_web_stats
table is not part of schema: ext_market_website_pref
table is not part of schema: stats_vast
table is not part of schema: upgrade_action
to version: 613
timing: constructive
target database: ****
table prefix: ox_
successfully initialised DB Upgrade
verifying/creating constructive tasklist
task found: doRemoveIndex__data_intermediate_ad_variable_value__data_intermediate_ad_
task found: doRemoveIndex__data_summary_zone_impression_history__operation_interval_i
task found: doAddIndex__data_intermediate_ad_variable_value__data_intermediate_ad_con
task found: doAddIndex__data_summary_zone_impression_history__operation_interval_id
#! database integrity check detected problems with the database
#! 2 indexes to remove
#! 2 indexes to add

 

Database name and hosting account name has been replaced with ***** for safety reasons, just to add as a note.

 

 

 

 

Anyone able to help what might be the problem?

Thanks

Share this post


Link to post
Share on other sites

I successfully upgraded from 2.8.10. to 2.8.11, and then tried to upgrade 2.8.11 to Revive 3.0.5., and same thing happens again.

There is definitely a problem with Revive upgrade flow from OpenX.

Share this post


Link to post
Share on other sites

I didn't bother trying to upgrade as discovered there were issues with OpenX to start with - although it takes time to do a fresh install, in the long run you may find it more beneficial to install Revive into a new folder with it's own database and then manually re-create your advertisers/campaigns/banners etc., easy enough to have two browser windows open and go through them so they are set up the way you want.

 

It is a pain if you have a lot to transfer and yes you will lose the existing stats, but frankly found it meant I could re-organise everything and take my time about it without losing any display time on the sites - when it was ready to go, I did a test by installing the new zone code into one of my sites and then copied the new zone codes into a text file so it was easy to use find/replace to change the openx invocation codes to revive codes. Took just one day to do the install and make the changes for 20+ advertisers and 10 sites :)

Share this post


Link to post
Share on other sites

Sorry for replying late. Well, updating was getting me nowhere, and since I haven't got any answers here on forum for few days, I decided it was time to do some manual work.

 

These are steps how I upgraded the OpenX installation manually:

  1. Downloaded latest Revive 3.0.5.
  2. Uploaded it to new folder on server
  3. Made a clean installation in new DB
  4. Copied old www/images folder to new Revive
  5. Manually copied db records table by table (you'll need some SQL skills here to do it correctly, as you'll probably have same problem as I did with prefixes, OpenX had ox_ and Revive has rv_)
  6. Tested new Revive
  7. Moved old OpenX (it was in a subdomain) and on that spot moved Revive (had to change paths in config file, very important!)

Running Revive 3.0.5 and works great, all statistics, campaigns, zones, advertisers, banners preserved.

Share this post


Link to post
Share on other sites

Hi,

Unable to upgrade either.

I am trying to upgrade my current installation: OpenX v2.8.7 running on Apache, PHP 5.3.28 and MySQL 5.1.67-rel14.3-log into Revive 3.0.5

After following the upgrade instructions found here: http://www.revive-adserver.com/support/upgrading/ now I have the following error message just after trying to start the update process within the new folder:

---
Warning: require_once(MAX_PATH/lib/max/Dal/Common.php) [function.require-once]: failed to open stream: No such file or directory in /home/multiple/public_html/adserver_new/variables.php on line 13

Fatal error: require_once() [function.require]: Failed opening required 'MAX_PATH/lib/max/Dal/Common.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/multiple/public_html/adserver_new/variables.php on line 13
---

How I can solve this issue so that the upgrade process may be completed?

Thanks in advance!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...