Jump to content
JanesOosthuizen

Help Upgrading On Root Instead Of Folder ( Subdomain )

Recommended Posts

Hi

 

I need help upgrading from OpenX 2.8.7 which is currently installed in the root folder of a subdomain. ads.mydomain.co.za.

 

The upgrade proccess explains it being in a directory on the main website. As explained above my scenario is different. I have tried setting it up on a new subdomain before upgrading the live copy but on my test copy it doesnt present me with the upgrade screen. Just a fresh install screen. The Upgrade guide isnt very clear. Am I supposed to overwrite the current files with the new files.. 

 

Sorry but I am bit in the dark at the moment. Any guidance or help will be much appreciated.

 

Thanks

Share this post


Link to post
Share on other sites
Guest

Hi  Try  to upgrade with your current domain (follow the upgrade guide)

 

 

Then ,

 

1.Move your current directory to sub domain directory

 

2.Rename the config file  mydomain.co.za.conf.php -> ads.mydomain.co.za.conf.php

 

3.open the ads.mydomain.co.za.conf.php , change all paths  from mydomain.co.za/www/admin to

[webpath]
admin="ads.mydomain.co.za/www/admin"
delivery="ads.mydomain.co.za/www/delivery"
deliverySSL="ads.mydomain.co.za/www/delivery"
images="ads.mydomain.co.za/www/images"
imagesSSL="ads.mydomain.co.za/www/images"

Also

[store]
mode=0
webDir="/home/chinnuad/public_html/ads/www/images"

Share this post


Link to post
Share on other sites
Guest

You can consider

 

From Upgrade guide

 

Revive Ad server installed in www.example.com/adserver/

 

www.example.com/adserver/  as  ads.mydomain.co.za

Share this post


Link to post
Share on other sites

I have the same setup.

 

My server is located at http://banners.mydomain.com

  • In the past, I created a folder at http://banners.mydomain.com/new_banners
  • I uploaded the latest version into the new_banners folder.
  • I COPIED the configuration file and the images folder into the new_banners folder
  • Then I used my browser and visited http://banners.mydomain.com/new_banners
  • OpenX recognized the upgrade script and I was able to run through the process just fine.
  • Finally, I moved all the files out of the root install and copied everything from the new_banners folder into the root install.

This made my upgrade live at the root level instead of the subfolder level.

 

This worked fine with OpenX.

 

Is that still the case when going from OpenX -> Revive?

Share this post


Link to post
Share on other sites

I have the same setup.

 

My server is located at http://banners.mydomain.com

  • In the past, I created a folder at http://banners.mydomain.com/new_banners
  • I uploaded the latest version into the new_banners folder.
  • I COPIED the configuration file and the images folder into the new_banners folder
  • Then I used my browser and visited http://banners.mydomain.com/new_banners
  • OpenX recognized the upgrade script and I was able to run through the process just fine.
  • Finally, I moved all the files out of the root install and copied everything from the new_banners folder into the root install.

This made my upgrade live at the root level instead of the subfolder level.

 

This worked fine with OpenX.

 

Is that still the case when going from OpenX -> Revive?

Yes, this should work just fine with Revive Adserver as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...