Jump to content

You Need To Enable Cookies Before You Can Use Revive Adserver


Recommended Posts



For my client, I tried to upgrade from an old version of openx to the last "Revive" 3.0.2 version.


As of the first step (1. Welcome) of the install.php page, I got the following error: "You need to enable cookies before you can use Revive Adserver".


My cookies are well enabled, I tried with several browsers.


I searched on the net where I found similar problems, and where they ask to use "date.timezone" instead of "date_default_timezone_get()" in the variable.php file.


The call to "date_default_timezone_get()" in the variable.php doesn't correspond to the line nbr described in the forums, but I changed where I found it (line 67).


But, no luck.


I'm completelly stucked, with the client on my back....


Can someone help me please ?


Thanks a lot




And just for info...


As I couldn't use the upgrade mechanism, I tried to rename the "UPGRADE" file under "/var" folder to "INSTALLED".


I put the .conf file of my previous Openx version to link to our database.


I can reach the webapp, but then, all my plugins are disabled and I got errors when I want to install/upgrade them.


This is how I want to launch a "real" upgrade, cause I suppose the plugins will be installed during this process.


So if you know a way to bypass the upgrade process and makes my server working, I'm interested !





Thanks a lot

Link to comment
Share on other sites

Yes, hey are all writable.


I just that my /www directory perms are 755 (but then /www/admin/plugins/, 777)


Could this be a problem ?


As a workaround, for the moment, I copied the content of /plugins folder of my old openx install to the new revive /plugins folder.


I re-enabled them through the admin interface.


It seems to work, but I'm afraid I could still have problems without this "no real upgrade" installation (reminder: I've renamed the "UPGRADE file to INSTALLED and put my old .conf file into /var).

Link to comment
Share on other sites

For info, my problem is solved.


Actually, we don't use the  /www/images folder. We have instead a symlink to a shared drive (we have 2 servers with a load balancer).


The permissions on the "images" files of the shared drive were not OK.


Case closed !


Thanks for your help

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...