Jump to content
edertch

Geotargeting Maxmind Only For Some Countries

Recommended Posts

Hi there,

 

using the adserver with the geotargeting plugin from maxmind.

Works perfectly well, but only for some countries (e.g. when I geotarget for Germany it works, when geotargeting for Namibia it does not). Maxmind said it is not a problem with their data, rather with Revive/OpenX.

 

Any ideas?

 

Cheers

edertch

Share this post


Link to post
Share on other sites

Could you please define what "works" vs. "doesn't work" means? I'm assuming that you are saying that when you target a banner to only be displayed if the user is coming from Nambia, you're seeing the banner appear for users not from Nambia, or something like that?

 

Do you have example IP addresses being used when things work vs. not working?

Share this post


Link to post
Share on other sites

Hi Andrew,

 

sorry for not being too clear.

 

Example 1:

Targeting banners only to show for Germany (German IP, e.g. 217.92.144.64) -> it is only shown to German IPs as wanted

 

Example 2:

Targeting banners only to show for Namibia (Namibian IP, e.g. 105.232.247.50) -> it shows no banners at all (although it should show to Namibian IPs)

 

Hope that clarifies the problem.

 

Many thanks

Christian

Share this post


Link to post
Share on other sites

Hi There,

 

tried a lots of solutions, however, Geotargeting is still not working.

 

Might be I am using the wrong path but it does not give out any error or so. Simply does not show any banners that I target to a specific country.

I am using this path in the maxmind plugin settings: Path to geoipCountryLocation file www.xyz123.com/public_html/advertising/GeoIP.dat.gz

 

MaxMind GeoIP Plugin 1.2.2
Revive Adserver v3.0.5
 
Any ideas?
 
Many thanks in advance
edertch

Share this post


Link to post
Share on other sites

Could someone maybe just briefly confrm that I am actually using the correct link in the settings of the plugin?

www.xyz123.com/public_html/advertising/GeoIP.dat.gz

I do not get an error, so I believe it should be correct.

 

Thanks

edertch

Share this post


Link to post
Share on other sites

Could someone maybe just briefly confrm that I am actually using the correct link in the settings of the plugin?

www.xyz123.com/public_html/advertising/GeoIP.dat.gz

I do not get an error, so I believe it should be correct.

 

 

Maybe you want a / at the start of the path, assuming that is a supposed to be an absolute path, rather than local? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...