Jump to content

Search the Community

Showing results for tags 'nginx'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Using and Managing Revive Adserver
    • Documentation
    • Using Revive Adserver
    • Managing Revive Adserver
    • Bugs
  • Advanced Topics
    • Performance, Scalability, and Reliability
    • For Developers
  • Revive Adserver Community
    • Revive Adserver Project News and Announcements
    • Feature Requests
    • Plugins
    • Requests for Consulting
    • Off Topic

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL

Found 5 results

  1. I think this Revive Adserver is great and can get it working with several 3rd party networks, except for Facebook audience. Facebook recently opened their advertising to mobile sites. If I create two banners, one for AdSense, and one for Facebook, and put them in the same zone, Revive Adserver will serve a blank ad constantly for Facebook, but serves AdSense fine. Anyone have any idea as to why this is happening? I'm not using this for the same reason everyone else is. The only thing I want to use it for is ad rotation. My server is a 24 core multi CPU dedicated with 16 gigs of ram that runs Nginx and PHP-FPM via the Ndeploy nginx stack. After installing the stack you can modify the configuration of Nginx to provide two separate caches, one for mobile, and one for desktop. Because of using Nginx, when I use standard plugins with my wordpress site like ad inserter and try to rotate ads, they'll only rotate about once or so an hour which I don't want. With Revive Adserver, if I can get it working with facebook audience ads for mobile web, I can run the adserver from a non nginx account and then the ads would rotate on every page refresh. I tried it that way and it was working, but it was rotating adsense with blank ads for facebook. I only get about 20m - 30m ad impressions on my site in a months time, so i think Revive Adserver should be able to handle that on the same server as long as it's in front of Nginx and not behind it? Also facebook appears to load their ads almost the same way as google adsense with the async style javascript, so I can't seem to figure out why it works with adsense but not facebook? B-T-W Facebook pays far better than Google Adsense does on mobile advertising, and the more people find out it, I'm sure the more questions will appear on here on how to get it to work.
  2. Hi all. Trying a fresh install of revive on nginx. Got the welcome screen, clicked accept to the terms, and got the check screen prompting me to change some file permissions. I do that as instructed, click retry and am redirected back to the welcome with the GPL terms. I click next and it says "checking system parameters," then refreshes that same screen. Here's my access.log tail: 108.162.215.109 - - [06/Mar/2015:05:55:03 +0000] "POST /www/admin/install.php?action=welcome HTTP/1.1" 302 5 "/www/admin/install.php?action=welcome" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36" 108.162.215.109 - - [06/Mar/2015:05:55:03 +0000] "GET /www/admin/install.php?action=check HTTP/1.1" 302 5 "/www/admin/install.php?action=welcome" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36" 108.162.215.109 - - [06/Mar/2015:05:55:03 +0000] "GET /www/admin/install.php?action=database HTTP/1.1" 302 5 "/www/admin/install.php?action=welcome" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36" 108.162.215.109 - - [06/Mar/2015:05:55:03 +0000] "GET /www/admin/install.php?action=welcome HTTP/1.1" 200 19485 "/www/admin/install.php?action=welcome" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36" If I erase that directory and do a fresh install I can repeat this process. I have mysql running, but haven't been prompted to input the connection info yet, so not sure if that could be it. Help?
  3. Hey guys, i have a problem and i wasn't able to find anything on google about this. So i loaded revive-adserver for a customer that's migrating from a windows setup, to a centos/percona master-master 2 nodes cluster. The cluster is working just fine, and he is serving google ads from this adserver, however when using both nodes, the impressions number recorded in the db was was way large than he had it before, and also google reported about half impressions as well, so it was clearly something wrong on our end. We removed 1 node from the load balancing, and we're sending all traffic to 1 node, and now the impressions recorded are half of what it was before, but still the impressions number is fairly larger than what google is reporting. The thing is i really want to know why we're getting inflated impressions when the traffic is the same, when using 2 servers. Our setup is CentOS 6.5, with php-fpm and nginx. PHP5.5, Percona Cluster 5.6. If anyone can point me to the right direction would be great, as i really don't know where to start right here. Thanks a bunch. Another thing that i wanted to mention. The 2 servers - i am syncing the disk data between both of them, and using 1 of them as master for local files. There's no impressions data that i might be overwriting right when i sync the data from the master to the slave right?
  4. Hi folks, i couldn't find any resources on this subject or at least no recent information. Im experiencing lots of timeouts in the apache error.logs, even though i increased the timeout settings to a very high amount. But thats not the idea behind this post. When i came to this company, the OpenX adserver was already set up and at version 2.4 oder 2.6 ( i can't quite remember ). During the years it was my task to update and maintain the server, even though i had barely any clue about it when i started. There were no companies or consultings around here, teaching me how to do it and so i had to google every part of the configuration, when it came to reported errors. Obviously there are some of the points, where i could have made minor or even major mistakes in the configuration but we just kept moving on with the already exisiting stuff and just adding/changing configuration without being 100% sure about whats happening. So now the time comes, that i want to set up a fresh server, including new apache/nginx and php configuration. Are there are any good recommendations to look for, regarding php settings? And what about Do's and Not Do's? Or is somebody even willing to write or share his/her setup? Im guessing this is not only interesting for me, as i know from all that troubleshooting, especially before revive-adserver, that its an biiiiiiig pain in the arse, not finding good resources with good information. Sorry for spelling mistakes as English is not my first language. thanks a lot in advance & kind greetings René
  5. Hey guys, I'm having a hard time setting up a large scale setup for revive 3.0.3. I'll explain what I'm doing and see if you could help me out on scaling things out or with something that I'm missing. My current architecture follows the bellow setup: 2x Portal - (EC2 m1.large) = ~ run smooth (30% cpu) from 0-5000 visitors (google realtime) or ~ 600 visits from nginx_status/fpm_status pages PHP+FPM with pm.dynamic and pm.maxchildren 512, with sysctl configs effective setted. no OPCache setted yet. 2x Revive - (EC2 m1.large) = ~ run critical and stops PHP+FPM with pm.dynamic and pm.maxchildren 512, with sysctl configs effective setted. no OPCache setted yet. http://imgur.com/0D7kgvd 1 RDS - (db.m1.xlarge) = was running high on connection count mostly because table locking, solved after migrating from MyISAM to InnoDB, and LG caching on nginx (so no visits/impression count) just clicking Runs the queries for the ad server to work, the picture bellow shows the situation for the setup http://imgur.com/1e86Gqe The PHP portal makes server side requests for the adserver ones, one of the main pages has at least 90 banners, so when it opens, it'll spawn as much as 1x90 multicurl per visit for each view. After that the client side will show the banners correctly and also make more 90 request for the LG's beacons. The problem now is to scale that thing out, am I missing something? how to run such a massive delivery/impression log with RDS? should I try differently? Thanks in advance for the help and please, make your self comfy for asking for more configs or any other questioing.
×
×
  • Create New...