Jump to content

Search the Community

Showing results for tags 'Install'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Using and Managing Revive Adserver
    • Documentation
    • Using Revive Adserver
    • Managing Revive Adserver
    • Bugs
  • Advanced Topics
    • Performance, Scalability, and Reliability
    • For Developers
  • Revive Adserver Community
    • Revive Adserver Project News and Announcements
    • Feature Requests
    • Plugins
    • Requests for Consulting
    • Off Topic

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL

Found 23 results

  1. Can anyone advise what I need to do to get a (new) plugin to attach itself to an existing controller? I have a plugin that adds a new table, and I want to have the data included in the Admin statistics reports for Advertisers & Campaigns. So far I have a "demo" that works by changing stats.php and adding the plugin directly to OA_Admin_Statistics_Delivery_Controller_GlobalAdvertiser // Prepare the stats controller, and populate with the stats $oStatsController = &OA_Admin_Statistics_Factory::getController ( $entity . "-" . $breakdown, $aParams ); require_once MAX_PATH . '/plugins/deliveryLog/oxLogDwellTime/DwellTime.php'; $dwplugin = & new OA_StatisticsFieldsDelivery_DwellTime (); // my plugin $oStatsController->addPlugin ( 'oxDwellTime', $dwplugin ); // add the plugin to the controller $oStatsController->aColumnVisible += $dwplugin->getVisibleColumns (); // add my fields to the controllers lists $oStatsController->aColumns += $dwplugin->getFields ( $oStatsController ); $oStatsController->aColumnLinks += $dwplugin->getColumnLinks (); $oStatsController->aEmptyRow += $dwplugin->getEmptyRow (); ... which is duplicating the logic from the controller's constructor. But what I want to do is to have my plugin registered, or extend, all the report controllers without doing the manual hack. I assume this is possible by registering something at install time, in the XML? Can someone point me to either a github project that does this, or suggest what I need to modify? Thanks.
  2. When installing on SLES12 running apache2 with php5 and MySQL DB on a separate machine I get massive list of error after the screen where I fill the DB parameters. It starts with: MESSAGE: Only variables should be assigned by reference TYPE: Strict FILE: /srv/adserver/lib/pear/MDB2/Driver/Datatype/Common.php LINE: 1101 DEBUG INFO: 1096 * a DBMS specific format. 1097 * @access public 1098 */ 1099 function quote($value, $type = null, $quote = true, $escape_wildcards = false) 1100 { 1101 $db =& $this->getDBInstance(); 1102 if (PEAR::isError($db)) { 1103 return $db; 1104 } 1105 1106 if (is_null($value)and continues with loads of "Non-static method PEAR::isError() should not be called statically" How can I fix this?
  3. Hi, I tray to install revive adserver but I did not succeed. http://php-utro.rhcloud.com/ads/ PHP version 5.5.9, or greater, was not detected I have PHP Version 5.4.40 http://php-utro.rhcloud.com/info.php I need some expert advice. Thank you.
  4. I am setting up the Revive Adserver on Mamp server and i created a database and a associated user in phpmyadmin. When i started the installation process it gives me following error. MDB2 Error: connect failed standaloneQuery: [Error message: Cannot connect to postgres nor template1 databases] Installation failed to create the database reviveDB Can anybody please guide me. Thanks in advance!
  5. Hi,.. i am trying to install/use revive-adserver, when i try to install i cant install ,.. when i fill up my database information then click continue but cant install , same page appear not installing ,... plz help me,.. and different way ,... i install from softaculous but does not work ,.. when i try to add new advertiser , that does not work ,.. plz help me ,.. recommend me,.. now i am using hostwinds Hosting,.. System Linux shared14.hostwindsdns.com 2.6.32-042stab104.1 #1 SMP Tue May 12 18:07:50 MSK 2015 x86_64 Server API LiteSpeed V6.9 Please help me ,.. How to install and work properly ,.. thank you Ramesh
  6. hi~ my server set is... os : centos 6.6 64bit yum install MariaDB-server MariaDB-client yum install nginx yum install php70-php yum install php70-php-fpm php70-php-cli php70-php-common php70-php-gd php70-php-json php70-php-soap php70-php-xmlrpc php70-php-mbstring php70-php-mcrypt php70-php-mysql php70-php-opcache php70-php-pear php70-php-xml php70-php-devel php70-php-imagick php70-php-mhash short_url enable session.auto_start enable but not installed.... error message... Fatal error: OX_Admin_UI_Install_InstallController::initInstallStatus(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "OX_Admin_UI_Install_InstallStatus" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/mentalclub/adserver/lib/OX/Admin/UI/Install/InstallController.php on line 133 phpmyadmin & wordpress & etc ... diffrent program is no problem... help me...
  7. Hi, I just tried to install Revive Adserver 3.0.3, but got a lot of error messages: MESSAGE: Assigning the return value of new by reference is deprecated TYPE: Deprecated FILE: /var/vhosts/www.gomorilap.sk/public_html/Revive/lib/pear/HTML/QuickForm.php LINE: 597 DEBUG INFO: 592 return $error; 593 } 594 $className = $GLOBALS['HTML_QUICKFORM_ELEMENT_TYPES'][$type][1]; 595 $includeFile = $GLOBALS['HTML_QUICKFORM_ELEMENT_TYPES'][$type][0]; 596 include_once($includeFile); 597 $elementObject =& new $className(); 598 for ($i = 0; $i < 5; $i++) { 599 if (!isset($args[$i])) { 600 $args[$i] = null; 601 } 602 } More can be found here: http://pastebin.com/0XQFSvWN I have not found any useful information in the forum. I'm using PHP 5.3.10 and Ubuntu Server. The documentation says it works: PHP 5.1.4+, 5.2.x, 5.3.x, 5.4.20+, 5.5.2+ Is there any patch for this? How does this application work on PHP 5.3+? Thanks in advance
  8. Hello; Please i need help installing Revive adserver on my cpanel, i keep get one error or the other.. and if i try to use ads.my.com.com/adserver i get a redirect loop error
  9. I can't install the Revive AdServer... I used few time this script before and never got this error... I really don't know where to find a solutions for that... I got this error: Forbidden You don't have permission to access /www/admin/install.php on this server. File permissions are set to 644 and 755. I already tried with 666 and 777 but no luck... Can somebody help me out with few good idea?
  10. Hi I've been having this screen after install, I have already check requirements and its all right with all of them. Already check folder and file permissions too. How can I fix the error and finish intallation? I couldn't post the hole message, it was too long... Thanks for the help MESSAGE: Redefining already defined constructor for class XML_Parser TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/pear/XML/Parser.php LINE: 204 DEBUG INFO: 199 * @param string $mode how this parser object should work, "event" for 200 * startelement/endelement-type events, "func" 201 * to have it call functions named after elements 202 * @param string $tgenc a valid target encoding 203 */ 204 function __construct($srcenc = null, $mode = 'event', $tgtenc = null) 205 { 206 parent::__construct('XML_Parser_Error'); 207 208 $this->mode = $mode; 209 $this->srcenc = $srcenc; MESSAGE: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead TYPE: Warning FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/pear/Date/TimeZone.php LINE: 3642 DEBUG INFO: 3637 Date_TimeZone::setDefault($_DATE_TIMEZONE_DEFAULT); 3638 } elseif (getenv('PHP_TZ') && Date_TimeZone::isValidID(getenv('PHP_TZ'))) { 3639 Date_TimeZone::setDefault(getenv('PHP_TZ')); 3640 } elseif (getenv('TZ') && Date_TimeZone::isValidID(getenv('TZ'))) { 3641 Date_TimeZone::setDefault(getenv('TZ')); 3642 } elseif (Date_TimeZone::isValidID(date('T'))) { 3643 Date_TimeZone::setDefault(date('T')); 3644 } else { 3645 Date_TimeZone::setDefault('UTC'); 3646 } 3647 // MESSAGE: Non-static method Date_TimeZone::isValidID() should not be called statically TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/pear/Date/TimeZone.php LINE: 3642 DEBUG INFO: 3637 Date_TimeZone::setDefault($_DATE_TIMEZONE_DEFAULT); 3638 } elseif (getenv('PHP_TZ') && Date_TimeZone::isValidID(getenv('PHP_TZ'))) { 3639 Date_TimeZone::setDefault(getenv('PHP_TZ')); 3640 } elseif (getenv('TZ') && Date_TimeZone::isValidID(getenv('TZ'))) { 3641 Date_TimeZone::setDefault(getenv('TZ')); 3642 } elseif (Date_TimeZone::isValidID(date('T'))) { 3643 Date_TimeZone::setDefault(date('T')); 3644 } else { 3645 Date_TimeZone::setDefault('UTC'); 3646 } 3647 // MESSAGE: Non-static method Date_TimeZone::setDefault() should not be called statically TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/pear/Date/TimeZone.php LINE: 3645 DEBUG INFO: 3640 } elseif (getenv('TZ') && Date_TimeZone::isValidID(getenv('TZ'))) { 3641 Date_TimeZone::setDefault(getenv('TZ')); 3642 } elseif (Date_TimeZone::isValidID(date('T'))) { 3643 Date_TimeZone::setDefault(date('T')); 3644 } else { 3645 Date_TimeZone::setDefault('UTC'); 3646 } 3647 // 3648 // END 3649 ?> 3650 MESSAGE: Non-static method Date_TimeZone::isValidID() should not be called statically TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/pear/Date/TimeZone.php LINE: 153 DEBUG INFO: 148 * @param string $id the time zone id to use 149 */ 150 function setDefault($id) 151 { 152 global $_DATE_TIMEZONE_DEFAULT; 153 if(Date_TimeZone::isValidID($id)) { 154 $_DATE_TIMEZONE_DEFAULT = $id; 155 } 156 } 157 158 /** MESSAGE: Non-static method Language_Loader::load() should not be called statically TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/OX/Extension/authentication/authentication.php LINE: 18 DEBUG INFO: 13 require_once MAX_PATH . '/lib/max/Plugin/Translation.php'; 14 require_once LIB_PATH . '/Plugin/Component.php'; 15 require_once 'Date.php'; 16 require_once MAX_PATH . '/lib/max/language/Loader.php'; 17 18 Language_Loader::load('settings'); 19 20 /** 21 * Plugins_Authentication is an parent class for Authentication plugins 22 * 23 * @package OpenXPlugin MESSAGE: Non-static method Language_Loader::load() should not be called statically, assuming $this from incompatible context TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/OX/Admin/UI/Install/InstallController.php LINE: 87 DEBUG INFO: 82 exit(); 83 } 84 @set_time_limit(0); 85 86 // load translations for installer 87 Language_Loader::load('installer'); 88 Language_Loader::load('default'); 89 Language_Loader::load('settings'); 90 Language_Loader::load('settings-help'); 91 92 // Setup oUpgrader MESSAGE: Undefined variable: PRODUCT_URL TYPE: Notice FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/max/language/en/installer.lang.php LINE: 32 DEBUG INFO: 27 $GLOBALS['strSystemCheck'] = "System check"; 28 $GLOBALS['strSystemCheckIntro'] = "The install wizard perfomed a check of your web server settings to ensure that the installation process can complete successfully. 29 Please check any highlighted issues to complete the installation process."; 30 $GLOBALS['strFixErrorsBeforeContinuing'] = "Configuration of your webserver does not meet the requirements of the {$PRODUCT_NAME}. 31 In order to proceed with installation, please fix all errors. 32 For help, please see our documentation and FAQs"; 33 34 $GLOBALS['strAppCheckErrors'] = "Errors were found when detecting previous installations of {$PRODUCT_NAME}"; 35 $GLOBALS['strAppCheckDbIntegrityError] = "We have detected integrity issues with your database. This means that the layout of your database 36 differs from what we expect it to be. This could be due to customization of your database."; 37 MESSAGE: Non-static method Language_Loader::load() should not be called statically, assuming $this from incompatible context TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/OX/Admin/UI/Install/InstallController.php LINE: 88 DEBUG INFO: 83 } 84 @set_time_limit(0); 85 86 // load translations for installer 87 Language_Loader::load('installer'); 88 Language_Loader::load('default'); 89 Language_Loader::load('settings'); 90 Language_Loader::load('settings-help'); 91 92 // Setup oUpgrader 93 $this->initUpgrader(); MESSAGE: Non-static method Language_Loader::load() should not be called statically, assuming $this from incompatible context TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/OX/Admin/UI/Install/InstallController.php LINE: 89 DEBUG INFO: 84 @set_time_limit(0); 85 86 // load translations for installer 87 Language_Loader::load('installer'); 88 Language_Loader::load('default'); 89 Language_Loader::load('settings'); 90 Language_Loader::load('settings-help'); 91 92 // Setup oUpgrader 93 $this->initUpgrader(); 94 $this->oTranslation = new OX_Translation(); MESSAGE: Non-static method Language_Loader::load() should not be called statically, assuming $this from incompatible context TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/OX/Admin/UI/Install/InstallController.php LINE: 90 DEBUG INFO: 85 86 // load translations for installer 87 Language_Loader::load('installer'); 88 Language_Loader::load('default'); 89 Language_Loader::load('settings'); 90 Language_Loader::load('settings-help'); 91 92 // Setup oUpgrader 93 $this->initUpgrader(); 94 $this->oTranslation = new OX_Translation(); 95 MESSAGE: Non-static method OA_Admin_Settings::isConfigWritable() should not be called statically, assuming $this from incompatible context TYPE: Strict FILE: /hsphere/local/home/hostingc1/hostinggc.net/openx/lib/OA/Upgrade/Configuration.php LINE: 30 DEBUG INFO: 25 $this->oSettings = new OA_Admin_Settings(); 26 // Use reference here 27 $this->aConfig =& $this->oSettings->getConfigArray(); 28 // set default configPath 29 $this->configPath = MAX_PATH.'/var/'; 30 if (!OA_Admin_Settings::isConfigWritable()) 31 { 32 return false; 33 } 34 } 35
  11. Hi, I need help how to resolve that problem. When I try to execute the install, show that message: http://www.gatavirtual.com/ad/ My server config is: PHP Version 5.4.30 Why ? Thank you.
  12. Hi Team, I m a newbie in revive i m trying to install revive on debian jessie i followed the steps mentioned in revive but i m unable to install revive.
  13. The documentation on the support page says: Well, the installation proccess for the current version (3.0.0) doesn't tell you that. At least on my server it didn't. So this is the list of folders on which you have to set the permissions to 777: openx_new/plugins openx_new/var openx_new/www/admin/plugins I hope this helps, and sorry for my english So, anyone knows which of those folders should be changed back to 755 after installation?
  14. I installed the Revive Adserver a one click install through my ISP Heart Internet. This has however installed an older version and I am trying to upgrade to the newest version. On running the upgrade installer I'm getting an error (see screenshot also) which is not letting me complete the upgrade due to a MYSQL user permission error, however I can't see anywhere in PHPMYADMIN where I can change permissions. In the Revive Adserver documentation under upgrading it says the following "Create this new database, and also make sure that the MySQL user “revive_adserver” has “all privileges” on the new database." Please help
  15. I'm looking for a way to make an external call during plugin installation/setup which *includes* processing a user prompt response. What I have so far is a javascript dialogue box prompt to the user, (which is fine). The problem I have is getting that value back to the plugin installation process (within the php preinstallscript), so that the value can be inserted into the configuration settings file. Like this during install: user prompt -> value -> plugin_settings_config. Perhaps I'm making this more complicated than it needs to be, but it seems to me an awkward handover, between client and server, and perhaps someone has already solved this before me. Maybe there's an obvious and easy hook which I am missing? Any helpful suggestions as to how to go about this appreciated. Cheers.
  16. Hi, thanks for making the software available, I downloaded the latest version and installed and a few issues were encountered. I'm hoping someone can help get me pointed in the right direction. The install instructions said there would be a screen that would prompt to change the folder permission settings, didn't see anywhere where this was shown. I looked for documentation in the readme.txt, installation instructions and I don't see what folders need to be changed. I tried making changes based on the upgrade instructions because that was all I could find. Can someone tell me what folders need to be changed? Other than that issue the install seemed to work, set it up (I was an openx free customer so I kind of know my way around the interface) when you click a panner I get a 403 error when it goes back to the server to the ck.php redirect page. Any Ideas what I can try? Thanks Roger
  17. I installed 3.1.0 and so far it looks very sweet. Banners appearing fine, admin and stats. functionality all there, (from what I've seen so far). Looking very good. Just thought you might like to have a positive feedback for a change
  18. Hi all. Trying a fresh install of revive on nginx. Got the welcome screen, clicked accept to the terms, and got the check screen prompting me to change some file permissions. I do that as instructed, click retry and am redirected back to the welcome with the GPL terms. I click next and it says "checking system parameters," then refreshes that same screen. Here's my access.log tail: 108.162.215.109 - - [06/Mar/2015:05:55:03 +0000] "POST /www/admin/install.php?action=welcome HTTP/1.1" 302 5 "/www/admin/install.php?action=welcome" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36" 108.162.215.109 - - [06/Mar/2015:05:55:03 +0000] "GET /www/admin/install.php?action=check HTTP/1.1" 302 5 "/www/admin/install.php?action=welcome" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36" 108.162.215.109 - - [06/Mar/2015:05:55:03 +0000] "GET /www/admin/install.php?action=database HTTP/1.1" 302 5 "/www/admin/install.php?action=welcome" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36" 108.162.215.109 - - [06/Mar/2015:05:55:03 +0000] "GET /www/admin/install.php?action=welcome HTTP/1.1" 200 19485 "/www/admin/install.php?action=welcome" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36" If I erase that directory and do a fresh install I can repeat this process. I have mysql running, but haven't been prompted to input the connection info yet, so not sure if that could be it. Help?
  19. hi! quick question, in the installation manual it mentions after installation, I will be prompted to change file permissions for a list of folders, but I was never given that instruction during installation. anyone have a list of what folders those are for 3.0.5? Thank you
  20. Hi On the last step of the installation, every plugin installation fails, then the result is this large list of errors. Details on the install.log file are: As I mentioned on another post, the installation didn't give instructions on folder permissions, but I changed some folders to 777 (details on my other post) but that didn't help. Does someone know what am I doing wrong? Thank You!
  21. Hello I am a new user to adserver and am trying to install v3.0.5. The installation complains that the folder permissions are not correct. I have run the chmod commands a number of times and as you can see below, the folders have the correct permissions but I cannot get beyond this screen. I've restarted httpd but that doesn't seem to help. I've set the owner to apache which is the username that httpd uses I've found the code checkFilePermission but I don't know php and haven't figured out how to enable debug output so I can see what it is actually failing with. Any help is appreciated Regards Phil File permission errors have been detected, and must be fixed before you can continue. To fix the errors on a Linux system, try typing in the following command(s): chmod -R a+w /var/www/html/adserver/var chmod -R a+w /var/www/html/adserver/var/cache chmod -R a+w /var/www/html/adserver/var/plugins chmod -R a+w /var/www/html/adserver/var/templates_compiled chmod -R a+w /var/www/html/adserver/plugins chmod -R a+w /var/www/html/adserver/www/admin/plugins chmod -R a+w /var/www/html/adserver/www/images For more help, please see the Revive Adserver documentation. /var/www/html/adserver/ drwxr-xr-x. 6 root root 4096 Jun 9 17:02 etc drwxr-xr-x. 21 root root 4096 Jun 9 17:02 lib drwxr-xr-x. 2 root root 4096 Jun 9 17:02 maintenance drwxrwxrwx. 2 root root 4096 Jun 10 11:44 plugins drwxr-xr-x. 3 root root 4096 Jun 9 17:02 scripts drwxrwxrwx. 5 root root 4096 Jun 9 17:02 var drwxr-xr-x. 6 root root 4096 Jun 9 17:02 www /var/www/html/adserver/var drwxrwxrwx. 2 root root 4096 Jun 9 17:02 cache drwxrwxrwx. 4 root root 4096 Jun 9 17:02 plugins drwxrwxrwx. 2 root root 4096 May 14 04:42 templates_compiled /var/www/html/adserver/var/plugins drwxrwxrwx. 2 root root 4096 May 14 04:42 DataObjects drwxrwxrwx. 2 root root 4096 May 14 04:42 recover /var/www/html/adserver/www drwxr-xr-x. 6 root root 12288 Jun 9 17:02 admin drwxr-xr-x. 4 root root 4096 May 14 04:42 api drwxr-xr-x. 2 root root 4096 Jun 9 17:02 delivery drwxrwxrwx. 3 root root 4096 Jun 9 17:02 images /var/www/html/adserver/www/admin drwxrwxrwx. 2 root root 4096 May 14 04:42 plugins
  22. I'm trying to install on an nginx server. It goes to the welcome screen, click agree and then it returns to the welcome screen. It looks like it's failing on the 'check' step... Suggestions?
  23. Greetings all. Last night I installed Revive and had a generally positive experience - it reminds me a lot of the old phpadsnew product. So I set up some basic zones, a default advertiser, some remnant campaigns, and went to bed. Everything is serving properly, but I have absolutely no stats. I've done about 100-150k pageviews since then, so there should definitely be data. Did I not set something up, a cron job somewhere? Any help is appreciated! Thanks!
×
×
  • Create New...