Jump to content

FvLW

Approved members
  • Content Count

    14
  • Joined

  • Last visited

  1. Hi, there is just the same error in my debug.log: count(): Parameter must be an array or an object that implements Countable I'm running Revive Adserver v4.2.1 based on nginx 1.14.2, PHP 7.3.11-1+0~20191026.48+debian10~1.gbpf71ca0 und MySQL 5.5.5-10.3.17-MariaDB-0+deb10u1-log. What do I have to change in order to solve the above issue? Regards Michael
  2. As far as I remember: I downloaded the files to my local pc and then uploaded them via ftp to the server
  3. Hello, I fixed all these nasty errors by upgradeing to the latest revive version Now everything is fine again! Thanks Michael
  4. The webserver displays the follwing two error messages: Error: mysql => Either the mysql or the pgsql extension must be loaded badPhpConfiguration => Your current PHP configuration does not meet requirements of Revive Adserver. To resolve the problems, please modify settings in your 'php.ini' file. I wonder why the first message claims about the missing mysql extension as revive suggests to change to mysqli. Is there any other place where I have to switch the module beside the config file?
  5. OK, the above file has been downloaded from github and added to the installation. Now its a kind of open_basedir error: Aug 10 10:48:16 +0000 OX-598c39f0566a6 [ warning] is_readable(): open_basedir restriction in effect. File(/usr/share/php/MDB2/Driver/Extended/mysqli.php) is not within the allowed path(s): (/var/customers/webs/mgfvlw/revive:/tmp:/var/lib/php/sessions) I forwarded this to my hoster
  6. Additional finding: the banners will ony be deliverd with the mysql driver after changing to the msqli driver no banners will be delviered The debug file shows the following error with the driver mysqli: Aug 10 10:29:16 +0000 OX-598c357c648e0 [ warning] require_once(/var/customers/webs/mgfvlw/revive/lib/OA/DB/Charset/mysqli.php): failed to open stream: No such file or directory
  7. Hello, we are running Revive ad server 3.2.4 with php 5.6.30-0+deb8u1 for a couple of month without any problems or issues. Today our hoster upgraded to php 7.0.22-1~dotdeb+8.1 The ad server is still delivering the banners but I'm not able to logon to the web interface (http error 500) The apache log show an errors as follows: [Thu Aug 10 08:07:48.628043 2017] [:error] [pid 27690] [client 87.158.213.252:63686] PHP Fatal error: Uncaught Error: Call to undefined method MDB2_Error::setFetchMode() in /var/customers/webs/mgfvlw/revive/lib/pear/DB/QueryTool/Query.php:299\nStack trace:\n#0 /var/customers/webs/mgfvlw/revive/lib/pear/DB/QueryTool/Query.php(273): DB_QueryTool_Query->connect(Object(MDB2_Error), Array)\n#1 /var/customers/webs/mgfvlw/revive/lib/pear/DB/QueryTool/EasyJoin.php(71): DB_QueryTool_Query->__construct(Object(MDB2_Error), Array)\n#2 /var/customers/webs/mgfvlw/revive/lib/pear/DB/QueryTool.php(57): DB_QueryTool_EasyJoin->__construct(Object(MDB2_Error), Array)\n#3 /var/customers/webs/mgfvlw/revive/lib/max/Dal/Common.php(157): DB_QueryTool->__construct(Object(MDB2_Error))\n#4 /var/customers/webs/mgfvlw/revive/lib/max/Dal/Common.php(77): MAX_Dal_Common->_getQueryTool(Object(MDB2_Error))\n#5 /var/customers/webs/mgfvlw/revive/www/admin/lib-sessions.inc.php(182): MAX_Dal_Common->__construct()\n#6 /var/customers/webs/mgfvlw/revive/www/admin/lib-sessions.inc.php(224): phpAds_SessionDataStore()\n#7 /var/customers/webs/mgfvlw/revive/lib/OA in /var/customers/webs/mgfvlw/revive/lib/pear/DB/QueryTool/Query.php on line 299, referer: https://werbung.waffen-online.de/www/admin/index.php MDB2 is not installed, neither with PHP 5.6 nor with PHP 7.0 The configuration file has been changed to mysqli: [database] type=mysqli Any ideas and hints are welcome! Michael
  8. Hi, the issue is solved - it was a bug with the men in front of the monitor :-) I forgot to disable the adblock stuff Thanks for your help Michael PS: a system copy is a copy of the system be doing a backup/restore of the database and the files to a different location
  9. Hi, this was the third try to perfome the upgrade. Even a system copy does not work - but the original installation works Michael
  10. Today I started an upgrade to 3.2.4 After the completion I have some strange errors: the dasboard is completly empty I'm not able to switch from the "Default Account" to "System Administrator" The install.log is appended .. By the way: all the XML files are located in the old installation under plugins/etc Any help is welcome :-) Regards Michael ========================================================================= cat install.log ========================================================================= Attempting to detect an existing Openads (aka. phpAdsNew) installation... PAN not detected Attempting to detect an existing Openads (aka. Max Media Manager 0.1) installation... MMM v0.1 not detected Attempting to detect an existing Openads (aka. Max Media Manager 0.3) installation... MMM v0.3 not detected Attempting to detect an existing Revive Adserver installation... Revive Adserver 3.2.1 detected This version can be upgraded Starting file-check for plugins... Plugin: openXBannerTypes - Unable to locate XML files Plugin: openXDeliveryLimitations - Unable to locate XML files Plugin: openX3rdPartyServers - Unable to locate XML files Plugin: openXReports - Unable to locate XML files Plugin: openXDeliveryCacheStore - Unable to locate XML files Plugin: openXMaxMindGeoIP - Unable to locate XML files Plugin: openXInvocationTags - Unable to locate XML files Plugin: openXDeliveryLog - Unable to locate XML files Plugin: openXVideoAds - Unable to locate XML files Finished file-check for plugins Starting file-check for plugins... Plugin: openXBannerTypes - Unable to locate XML files Plugin: openXDeliveryLimitations - Unable to locate XML files Plugin: openX3rdPartyServers - Unable to locate XML files Plugin: openXReports - Unable to locate XML files Plugin: openXDeliveryCacheStore - Unable to locate XML files Plugin: openXMaxMindGeoIP - Unable to locate XML files Plugin: openXInvocationTags - Unable to locate XML files Plugin: openXDeliveryLog - Unable to locate XML files Plugin: openXVideoAds - Unable to locate XML files Finished file-check for plugins ========================================================================= Attempting to detect an existing Openads (aka. phpAdsNew) installation... PAN not detected Attempting to detect an existing Openads (aka. Max Media Manager 0.1) installation... MMM v0.1 not detected Attempting to detect an existing Openads (aka. Max Media Manager 0.3) installation... MMM v0.3 not detected Attempting to detect an existing Revive Adserver installation... Revive Adserver 3.2.1 detected This version can be upgraded ========================================================================= Attempting to detect an existing Openads (aka. phpAdsNew) installation... PAN not detected Attempting to detect an existing Openads (aka. Max Media Manager 0.1) installation... MMM v0.1 not detected Attempting to detect an existing Openads (aka. Max Media Manager 0.3) installation... MMM v0.3 not detected Attempting to detect an existing Revive Adserver installation... Revive Adserver 3.2.1 detected This version can be upgraded ========================================================================= Attempting to detect an existing Openads (aka. phpAdsNew) installation... PAN not detected Attempting to detect an existing Openads (aka. Max Media Manager 0.1) installation... MMM v0.1 not detected Attempting to detect an existing Openads (aka. Max Media Manager 0.3) installation... MMM v0.3 not detected Attempting to detect an existing Revive Adserver installation... Revive Adserver 3.2.1 detected This version can be upgraded Database settings and permissions are OK Starting file-check for plugins... Plugin: openXBannerTypes - Unable to locate XML files Plugin: openXDeliveryLimitations - Unable to locate XML files Plugin: openX3rdPartyServers - Unable to locate XML files Plugin: openXReports - Unable to locate XML files Plugin: openXDeliveryCacheStore - Unable to locate XML files Plugin: openXMaxMindGeoIP - Unable to locate XML files Plugin: openXInvocationTags - Unable to locate XML files Plugin: openXDeliveryLog - Unable to locate XML files Plugin: openXVideoAds - Unable to locate XML files Finished file-check for plugins Starting file-check for plugins... Plugin: openXBannerTypes - Unable to locate XML files Plugin: openXDeliveryLimitations - Unable to locate XML files Plugin: openX3rdPartyServers - Unable to locate XML files Plugin: openXReports - Unable to locate XML files Plugin: openXDeliveryCacheStore - Unable to locate XML files Plugin: openXMaxMindGeoIP - Unable to locate XML files Plugin: openXInvocationTags - Unable to locate XML files Plugin: openXDeliveryLog - Unable to locate XML files Plugin: openXVideoAds - Unable to locate XML files Finished file-check for plugins Starting file-check for plugins... Plugin: openXBannerTypes - Unable to locate XML files Plugin: openXDeliveryLimitations - Unable to locate XML files Plugin: openX3rdPartyServers - Unable to locate XML files Plugin: openXReports - Unable to locate XML files Plugin: openXDeliveryCacheStore - Unable to locate XML files Plugin: openXMaxMindGeoIP - Unable to locate XML files Plugin: openXInvocationTags - Unable to locate XML files Plugin: openXDeliveryLog - Unable to locate XML files Plugin: openXVideoAds - Unable to locate XML files Finished file-check for plugins Starting file-check for plugins... Plugin: openXBannerTypes - Unable to locate XML files Plugin: openXDeliveryLimitations - Unable to locate XML files Plugin: openX3rdPartyServers - Unable to locate XML files Plugin: openXReports - Unable to locate XML files Plugin: openXDeliveryCacheStore - Unable to locate XML files Plugin: openXMaxMindGeoIP - Unable to locate XML files Plugin: openXInvocationTags - Unable to locate XML files Plugin: openXDeliveryLog - Unable to locate XML files Plugin: openXVideoAds - Unable to locate XML files Finished file-check for plugins Another issue I observe: I'm not able to use any dropdown lists
  11. Hello, today we are using banners in gif, jpg and png with a fixed size of 468 x 60 px. These banners are to wide to be displayed in an acceptable form on mobile devices. I've been told that there is a MMA Guideline regarding this. Will Revive support this standard? What can I do to use different banner sizes dpendinmg on the users device? Michael
  12. Hi, after some additional try & error work (e.g. reinstalling the plugins) new stats are available, but not the older ones. So there is a gap starting 2015-07-13 19:00 and ending 2015-11-13 17:59 Is there a realistic chance to recover these missing values? Regards Michael
  13. Hi, after some try & error word the debug.log looks as follows: but there are still no stats fore the time after July 13 available :-( Any ideas or hints? Michael
  14. Hi, today I realized that theer no stats any more since I upgraded from revice 3.0.2 to revive 3.2.1 on July 13th 2015 A snapshot from the actual debug.log looks like this: Are there any ideas what can be happened and how to get the ststistics up and running again? Regards Michael
×
×
  • Create New...