Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. Yesterday
  3. Last week
  4. Has anyone else had an ad tag blocked on GAM for being linked to the malvertising domain adsnetclick.com We've never worked with this domain but publishers are getting a "Blocked for Malvertising" message on GAM when they try to implement our tags. Is it possible that this malvertising network may have infiltrated our Revive install via some vulnerability to link its banners to Revive tags?
  5. Did some more digging and will consider this question closed for now... Using the javascript code to invoke the zone seems to be the only way for me to get the desired output. I just had to and in one line of code for the variable/value to be passed in. Now all 3 zones are loading random banners based on the variable "paysite" value I pass in.
  6. Since I kept digging.. (still am) I noticed that my browser console looks like it is only showing one call to: VM13246:1 XHR finished loading: GET "https://MYSERVER.com/www/delivery/asyncspc.php?zones=33%7C1%7C40%7C41%7C42&prefix=revive-0-&target=_blank&pref=A&paysite=220&block=1&loc=https%3A%2F%MYDOMAIN.com%2F". In my first post you'll notice that I was only declaring the async call once in the header.. I have also tried invoking under each banner tag and still get the same issue. It makes sense now why all the zones w/ the particular rules are loading the banners from the same campaign.. what DOESN'T make sense is why in call to to asynspc.php is there only one variable rule. The call above shows URL var zones=33,40,41,42 BUT it only has one value for the var paysites=220. Theoretically the variable paysite should have 3 values..
  7. Hey Everyone, I have 3 Zones in the footer of a site. Zone 1, 2 and 3. Each Zone has the same exact banners in them. Each banner invocation tag has the same rule set where they should pull a banner based on the variable rule passed in. For example: <head> <script async src="//MYSERVER.com/www/delivery/asyncjs.php"></script> </head> <ins data-revive-zoneid="<? echo $footer_home_1_zone; ?>" data-revive-paysite="<?php echo getRandPaysite1($_SESSION['filterType']); ?>" data-revive-target="_blank" data-revive-id="<? echo $revive_id; ?>"></ins> <ins data-revive-zoneid="<? echo $footer_home_2_zone; ?>" data-revive-paysite="<?php echo getRandPaysite2($_SESSION['filterType']); ?>" data-revive-target="_blank" data-revive-id="<? echo $revive_id; ?>"></ins> <ins data-revive-zoneid="<? echo $footer_home_3_zone; ?>" data-revive-paysite="<?php echo getRandPaysite3($_SESSION['filterType']); ?>" data-revive-target="_blank" data-revive-id="<? echo $revive_id; ?>"></ins> So the data rule set being passed on the banner end is (every banner has this rule applied to them respectively to their campaign): Site - Variable "is equal to" Name: paysite Value: 320 (for example sake) In my invoke tags I call 3 separate functions that return a random "paysite" number. ( I know this can all be done w/ the same function call, but created 3 to debug). The php and invoke tags are all being written to and output in the code correctly BUT the the zones are not displaying the correct banners. What IS happening is the last zone (zone 3) is producing the correct banner to its rule set and then zone 1 and 2 are displaying banners from that same campaign. So basically it seems like the last called zone is somehow interfering with what the previous two zones should show - even though the invoke code is all correct. I have looked in the debug log - but I see nothing at all in regard to zones and rule sets. I will continue to search and try to debug, but if anyone sees anything blatantly incorrect with my logic or has run across this issue, I am all ears.
  8. I bet this topic already is in a forum, but had a little trouble finding it. I apologize in advance. Thanks to having a robust clientele and lots of advertising, our database is also getting really big. Are there tips on how to prune the database to keep its size manageable? For example, I have emptied the _userlog table. I don't really need to see who's logged or when. It was good for about 1.5 MB. The biggest tables are data_intermediate_ad and data_summary_ad_hourly. Is it safe th empty those? Or, is there a recommendation on how to at least prune them? I can run sql commands, but am only at an intermediate skill level on that. So, any help construction such commands would be appreciated. Thanks!
  9. Ok so my install is up and running and after first login it is configured, everything just fine (kinda I have ad issues but thats for another thread) but now when i go to login it keeps me in a loop ... here i will capture a screen recording of it and share ... it will "kind of" log me in to the admin... like the first page will load one of the panels of content but not the others ... and only to the "default manager" account not the "Administrator" account .... the link below is to a 2 minute screen-cast i recorded detailing the issue .... im new to the community but i'm an old OpenX user just haven't used this since about 2012... once i solve this issue there's another issue i've posted that i can also detail with a screencast once this one is resolved ... https://screencast-o-matic.com/u/Vgtw/revivloginissue
  10. lol, hold on this theres another issue ... ill post another thread as its different ...
  11. https://documentation.revive-adserver.com/display/DOCS/Banners+Not+Delivering
  12. Earlier
  13. Hi I am having issues getting my ad to display .. I have 1 advertiser, 1 banner in one linked zone and for some reason the invocation code that I have inserted into a php template of my wordpress theme only shows the ad IF i am logged in to the administrative area of wordpress ... crazy sounding i know ... i've tried everything from using each of the different invocation codes to uninstalling and reinstalling the ad server .... heres the weird thing the code shows in the source up BUT if I am not logged in to the wordpress admin it displays a 0px height and 0px image as the ad instead of the 728x90 banner i have placed ... you can view this by going to the page: https://www.amtaflorida.org you will see at the top where the log is above the navigation where the ad should display ... if you look at the source it should give you an idea of whats going on ... help i simply cant figure this out and i feel I have tried everything ...
  14. Yes, someone from Revive team. We are in the process to open source our IMS(inventory management system) and would like to integrate with Revive. To do that we would like to chat with Revive team first to see if it is possible.
  15. Thanks a lot! I guess I did not search enough, because I did not find those articles. 😕 Anyway, I have imported the code for the 3 plugins in question and seen from the backend, all seems to be fine. Only at the details of "IAB VAST Video Player Plugin" and "IAB VAST Report Plugin" there is not table at all. (So also not a number in the Group column as a sign of a broken plugin.) But maybe this is normal? Also, the /www/admin/extensions folder and its contents have not been re-created by importing the code … I am not sure if it's really fixed. I did/do not notice any malfunctions, except during update, but I am not using Video ads.
  16. Hi Andrew, thats totally OK with me, I was just confused about some news it went to the latest version...please read this article: https://www.revive-adserver.com/blog/help-us-test-the-upgrade-of-geotargeting-rules-to-geoip2/ I suggest to update it, so there is no confusion about it. Thanks!
  17. Not sure what you mean by "staff" - do you mean the core Revive Adserver team?
  18. Hi, there, I would like to send a message to staff, how can I do it? I always got the error message like "you are only allowed to send 0 message". regards, -xun
  19. There is no native support for this, no. However, depending on your system, you may be able to mount the S3 Bucket as a filesystem, and point Revive Adserver to that mount point for image storage.
  20. https://documentation.revive-adserver.com/display/DOCS/Plugins+Incorrectly+Upgraded and https://documentation.revive-adserver.com/display/DOCS/Plugins+Missing+or+Disabled should cover you here.
  21. Most correct answer, as far as I am concerned: The user that your web service runs as needs permissions to read all directories (and all of the files and sub-directories) of the entire Revive Adserver installation; and The user that your web service runs as needs permission to write to all of the specifically listed directories (and all of the files and sub-directories underneath them). There you go - that's my view on the most correct answer - and you will notice I not said anything about how you should achieve that. This is because I can think of a number of different ways to do this, depending on your operating system and/or preferences about how you manage security. So, while it's the most correct answer, it's of absolutely no help to many (most?) of our users, because they don't have the technical experience needed to set this up. That's why we suggest something rather permissive in our documentation - we don't have time to support every single new user installing the software to get a custom setup that's just right for their security needs. We assume that if you're the kind of user who is concerned about getting the security requirements just right, then you have the capability to tweak the permissions to what your needs are. HTH!
  22. Hi @andrewatfornax I'm just about to upgrade my revive server and in the process i started to go over the file perms and the documentation about it. I must admit after reading the docs and this thread I'm really confused about it. The page https://www.revive-adserver.com/support/upgrading/ tell you to use 777, but here in the thread it is NOT advised at all.(The documentation should really be updated to the correct file permission recommendations and not 777, and I too really dislike to use 777 too because it is dangerous for obvious reasons.). You also say here that you would not recommend anyone to use that permission etc. So I am kindly asking for the benefit of everyone and anyone that uses Revive Adserver if this could be settled once and for all? What is exactly the absolutely correct permissions for files and directories as they clearly should not run on 777 for a vanilla Revive server. Could you please clearly cut this out in the sand what permissions in that should be used for a vanilla/standard installation? For folders permission number? var var/cache var/plugins var/templates_compiled plugins www/admin/plugins www/images and for files permission number? It would be great to have this cleared once and for all. All this contradicting information makes no good for anyone. Not for the Revive community and neither for Revive Adserver as product itself. Thanks a lot in advance. Kind regards AngryWarrior
  23. Hello there. I just updated to 4.2.1 and found a problem while importing plugins using the upgrade wizard, which probably was caused during the previous update. The mistake during the previous update was to enter a path containing ~ as path of the previous installation, and because this failed copying the plugins folder manually. From install.log during this update now, with correct full path given, I found that the wizard was unable to find many files in "/www/admin/extensions/" (most in "/www/admin/extensions/videoReport/") and one specific file "/extensions/bannerTypeText/oxText/genericText.delivery.php" I searched the folders of the old (4.2.0) installation and the new, but both "extensions" folders do not exist at all. According to the log, at the end 3 plugins failed to import correctly: Plugin: openXBannerTypes - Unable to locate XML files Plugin: openXDeliveryLimitations - Unable to locate XML files Plugin: openXVideoAds - Unable to locate XML files However, all plugins are shown now in Admin menu, no errors or warnings here, and Revive 4.2.1 is working fine. Note that we are not using Video ads… but I am sure the plugins installation is not valid. How can I check the consistency and how can I fix this? Should I uninstall the plugins and reinstall them?
  24. Thank you very much for your review. I think I know which "best-know plugin developer" u are talking about! And I say thank you because when I discovered Revive, I also fell in love and then look for plugins to make revive "perfect" and I found that "best-know plugin developer".
  25. Is there any way we can upload banners on Amazon S3 Bucket?
  26. I also tried to remove all modes from sql_mode, still same thing... in fact it kind of made it even worse... as database wouldn't get created, but even if I create database manually, I end up with same 2 tables as before and "Installation failed to create the core tables " message on screen...
  27. It appears to be resolved in the admin control panel, however you missed updating the email that goes out advising of expiration. Example for an August expiration email notification The campaign belonging to XXX shown below is due to end on 01-08-2019. This should read 08-01-2019 for US format
  1. Load more activity


×
×
  • Create New...